Zweiter Frühling für ION-Antrieb --- Sparta, Batavus, Koga ...

Diskutiere Zweiter Frühling für ION-Antrieb --- Sparta, Batavus, Koga ... im Nabenmotoren Forum im Bereich Fertig-Pedelecs; @Uli2412 I parsed the log you provided (see attachment), it actually looks surprisingly good :) Below are the first lines from the start, I see...
V

void-spark

Dabei seit
08.09.2021
Beiträge
222
Punkte Reaktionen
91
@Uli2412 I parsed the log you provided (see attachment), it actually looks surprisingly good :)

Below are the first lines from the start, I see (among others):
- Turning on the motor, with a response from the motor: 0120-30 > 2200-30
- Enabling assist (doesn't provide power yet here, level '0'): 0120-32 > 2200-32
- Set assist level '3': 2200-34 > 2200-34
- Motor getting the display serial: c100-20 > 02c8-20c211490000000306

So actually looks quite ok! Surprisingly everything is working at 9600 baud too :)
Handoffs keep going, which is good, you want the communication to keep going for it to work.
Your display serial# is 'c2-11-49-00-00-00-03-06', in case you wondered :)

Thoughts:
- I don't see the ESP32 sending the calibration data, that might be the problem, I guess the new XHP 'PING' messages and/or new GET DATA 002a throw off the ESP32 firmware, before it sends the calibration data.
- Just to double check, the display and the motor are paired right? :) (I would guess so if you bought them together).
- I think the button presses work slightly different from what I thought, since it goes directly to assist mode '3', in this log it looks good though, after going to mode '3' it stays there.

I will continue removing CU2 support from the firmware, and then build you a new binary, that should work with a bit of luck, since it will handle calibration correctly :)

Code:
tgt:MT typ:1 src:BT [10-0120-30-14] [30] - TURN ON
tgt:BT typ:2 src:MT [10-2200-30-8b] [30] - TURN ON - OK
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:06 typ:4 src:MT [10-6400-0b] - PING!
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:1 src:BT [10-0128-0994b009c414b10114-a1] [0994b009c414b10114] - PUT DATA 94b009c414b10114
tgt:BT typ:2 src:MT [10-2201-0900-d6] [0900] - PUT DATA - OK 00
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:06 typ:4 src:MT [10-6400-0b] - PING!
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:1 src:BT [10-0120-32-75] [32] - ENABLE ASSIST
tgt:BT typ:2 src:MT [10-2200-32-ea] [32] - ENABLE ASSIST - OK
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:06 typ:4 src:MT [10-6400-0b] - PING!
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:1 src:BT [10-0121-3403-1e] [3403] - SET ASSIST LEVEL 03 > POWER
tgt:BT typ:2 src:MT [10-2200-34-49] [34] - SET ASSIST LEVEL - OK
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:06 typ:4 src:MT [10-6400-0b] - PING!
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:1 src:MT [10-2102-08002a-3e] [08002a] - GET DATA 002a
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:1 src:MT [10-2102-08002a-3e] [08002a] - GET DATA 002a
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:1 src:MT [10-2102-08002a-3e] [08002a] - GET DATA 002a
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:1 src:MT [10-2102-08002a-3e] [08002a] - GET DATA 002a
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:1 src:MT [10-210a-0994c0000008c100000000-15] [0994c0000008c100000000] - PUT DATA 0000 000000 (94c0000008c100000000)
tgt:MT typ:2 src:BT [10-0221-0900-ab] [0900] - PUT DATA - OK 00
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:4 src:MT [10-2400-de] - PING!
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:4 src:MT [10-2400-de] - PING!
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:4 src:MT [10-2400-de] - PING!
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:4 src:MT [10-2400-de] - PING!
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:DP typ:1 src:MT [10-c100-20-03] [20] - GET DISPLAY SERIAL#
tgt:MT typ:2 src:DP [10-02c8-20c211490000000306-29] [20c211490000000306] - GET DISPLAY SERIAL# - OK c211 0306 (c211490000000306)
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:1 src:MT [10-210a-0994c0000008c100000000-15] [0994c0000008c100000000] - PUT DATA 0000 000000 (94c0000008c100000000)
tgt:MT typ:2 src:BT [10-0221-0900-ab] [0900] - PUT DATA - OK 00
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:1 src:MT [10-2101-1201-41] [1201] - MYSTERY BATTERY COMMAND 12 01
tgt:MT typ:2 src:BT [10-0220-12-9f] [12] - MYSTERY BATTERY COMMAND 12 - OK
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:0        [10-20-68] - HANDOFF
 

Anhänge

  • output_2022-05-20_09-28-58.txt
    239,8 KB · Aufrufe: 6
V

void-spark

Dabei seit
08.09.2021
Beiträge
222
Punkte Reaktionen
91
@Uli2412 Ok, I updated the code to remove CU2 support (configurable).
Also I renamed the branches, the one I work on is now 'master' again, so it's the one that shows up first under: GitHub - void-spark/ion1: ESP32 firmware to drive a Sparta Ion motor

I built a new firmware, with:
- ESP32 support (so the big chip, not ESP32-C3)
- CU2 display support disabled
- Better XHP support

I attached a zipfile which holds just the new ion1-nowifi.bin

You can flash it again using the same instructions as before:
Zweiter Frühling für ION-Antrieb --- Sparta, Batavus, Koga ...

You only need to flash the one file, you don't need to flash the bootloader of partion table again (they are not changed).
So you only need to fill in:
1653080279962.png


After flashing it, try it like before. You might need a couple more button presses to get to 2 flashes.
You should not have to do the calibration, the calibration data won't be overwritten.

If it works, party :)
If it doesn't work, attach uart, go through the same sequence from start/power on, and send the full logs :)
 

Anhänge

  • firmware.zip
    131 KB · Aufrufe: 4
V

void-spark

Dabei seit
08.09.2021
Beiträge
222
Punkte Reaktionen
91
PS, this is not a tested firmware, I don't have one of the original ESP32s wired up right now :)
 
U

Uli2412

Dabei seit
02.04.2022
Beiträge
50
Punkte Reaktionen
5
Your display serial# is 'c2-11-49-00-00-00-03-06', in case you wondered :)
A little bit too much 00 in the middle, but the numbers are ok.

- Just to double check, the display and the motor are paired right? :) (I would guess so if you bought them together).
I drove about 1000km with this combination. It worked until the battery breakdown.

Hello void-spark,

thanks for the work til late night :)!
I started with the new software, but it had no assistance on the motor. Sometimes this software has apparently an error: The red LED (the one who is "always" on) goes out and there is no communication anymore. I have one log immediately before breakdown.
There is another log, where I pushed the boot button until the green LED (the new one on GPIO2) blinked 3 times. After that I tested the motor assistance and also I tried to increase the assistance by the handlebarbutton. The display reacted on the buttonpress by increasing the powerlevel.

Maybe you can get information by the logfiles.

The displayed accu capacity is 0%-> maybe you have to fake this in order to let the motor run?
Maybe the motor needs some kind of (faked) message from the BLM. If you want to implement a test: my battery serial nr is:
G71151000573

Best regards
Uli

P.S.: The reset (EN) button seems not to work anymore.
 

Anhänge

  • Start 3 blinks.txt
    103,7 KB · Aufrufe: 12
  • before dead.txt
    16,5 KB · Aufrufe: 5
Zuletzt bearbeitet:
V

void-spark

Dabei seit
08.09.2021
Beiträge
222
Punkte Reaktionen
91
Quick note before I look at the rest, red led going out is a concern, that means it's lost power, could be bad connection, low input voltage for some reason, or a short somewhere, so probably worth checking your wiring, don't want to break anything! Software cannot turn off the red led :)
 
V

void-spark

Dabei seit
08.09.2021
Beiträge
222
Punkte Reaktionen
91
And some smaller notes before I dive into the logs:
A little bit too much 00 in the middle, but the numbers are ok.
Yup, that's expected, the serial in the chips seems to be longer than the ones on the stickers, they pad the middle with 0's :)

There is another log, where I pushed the boot button until the green LED (the new one on GPIO2) blinked 3 times.
After that I tested the motor assistance
Ok, I'll look at that log right after this, it should be the most interesting :)

and also I tried to increase the assistance by the handlebarbutton. The display reacted on the buttonpress by increasing the powerlevel.
Right now nothing on the CU3 display or connected to it will make any difference, the chip ignores it, the CU3 is only there to provide the serial to the motor.
CU3 support will be my next project :)

The displayed accu capacity is 0%-> maybe you have to fake this in order to let the motor run?
Maybe the motor needs some kind of (faked) message from the BLM. If you want to implement a test: my battery serial nr is:
G71151000573
Nah, the motor doesn't ask the capacity, by my own tests I know pretty well what either motor needs now, a few commands and the right serial is all :)

P.S.: The reset (EN) button seems not to work anymore.
Odd, although if that's with the power LED off, the bigger problem is no power. I really hope nothing got fried o_O

Ok, digging in the log now :)
 
V

void-spark

Dabei seit
08.09.2021
Beiträge
222
Punkte Reaktionen
91
Ok, looked at logs :)

Hmm, first, I mentioned missing calibration data with the old firmware, but looking at other logs now, it seems the XHP doesn't ask for the calibration data.
So that was actually as it should be. Maybe it remembers calibration values itself?

For 'Start 3 blinks':
The starts of your logs look good, from the first button press (motor 'on'):
Code:
tgt:BT typ:0        [14-20-30] CRC MISMATCH - HANDOFF
Incomplete: 14 crc:0x07
tgt:MT typ:1 src:BT [10-0120-30-14] [30] - TURN ON
tgt:BT typ:2 src:MT [10-2200-30-8b] [30] - TURN ON - OK
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:4 src:MT [10-2400-de] - PING!
tgt:MT typ:3 src:BT [10-0320-b9] - PONG!
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:1 src:BT [10-0128-0994b009c414b10114-a1] [0994b009c414b10114] - PUT DATA 94b009c414b10114
tgt:BT typ:2 src:MT [10-2201-0900-d6] [0900] - PUT DATA - OK 00
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:1 src:MT [10-2102-08002a-3e] [08002a] - GET DATA 002a
tgt:MT typ:2 src:BT [10-0224-0800002a01-b2] [0800002a01] - GET DATA - OK 01b2  (00002a01)
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:1 src:MT [10-210a-0994c0000008c100000000-15] [0994c0000008c100000000] - PUT DATA 0000 000000 (94c0000008c100000000)
tgt:MT typ:2 src:BT [10-0221-0900-ab] [0900] - PUT DATA - OK 00
tgt:BT typ:0        [10-20-68] - HANDOFF

We see a motor turn on command, and the acknowledgment by the motor, so that's good.
We now respond correctly to motor PINGs too.
And we respond correctly to the 002a get datas.
Motor also starts sending details correctly (speed).

Later we can see the second button press (assist level 1):
Code:
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:1 src:BT [10-0120-32-75] [32] - ENABLE ASSIST
tgt:BT typ:2 src:MT [10-2200-32-ea] [32] - ENABLE ASSIST - OK
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:DP typ:1 src:MT [10-c100-20-03] [20] - GET DISPLAY SERIAL#
tgt:MT typ:2 src:DP [10-02c8-20c211490000000306-29] [20c211490000000306] - GET DISPLAY SERIAL# - OK c211 0306 (c211490000000306)
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:1 src:BT [10-0121-3401-7f] [3401] - SET ASSIST LEVEL 01 > ECO
tgt:BT typ:2 src:MT [10-2200-34-49] [34] - SET ASSIST LEVEL - OK
tgt:MT typ:0        [10-00-b1] - HANDOFF
tgt:BT typ:1 src:MT [10-2101-1201-41] [1201] - MYSTERY BATTERY COMMAND 12 01
tgt:MT typ:2 src:BT [10-0220-12-9f] [12] - MYSTERY BATTERY COMMAND 12 - OK
tgt:BT typ:0        [10-20-68] - HANDOFF
tgt:MT typ:0        [10-00-b1] - HANDOFF

Also looks good
Enable assist command to the motor is acknowledged
The motor requests and gets the serial from the display (c211490000000306)
Assist level 1 command to the motor is is acknowledged
At this point we should already have (low power) assist!

From the logs the system then powered off, and started again just like above, still looks good though :)

Then third button press, to assist level 2:
Code:
tgt:MT typ:1 src:BT [10-0121-3402-8f] [3402] - SET ASSIST LEVEL 02 > NORMAL
tgt:BT typ:2 src:MT [10-2200-34-49] [34] - SET ASSIST LEVEL - OK

Still good :)

And fourth button press, assist level 4:
Code:
tgt:MT typ:1 src:BT [10-0121-3403-1e] [3403] - SET ASSIST LEVEL 03 > POWER
tgt:BT typ:2 src:MT [10-2200-34-49] [34] - SET ASSIST LEVEL - OK

Full power! So far everything looks good, and there should be full assist here!

I can see the bike moving a bit after that:
Code:
tgt:BT typ:1 src:MT [10-210a-0994c0003708c100000000-c5] [0994c0003708c100000000] - PUT DATA 0037 000000 (94c0003708c100000000)
tgt:MT typ:2 src:BT [10-0221-0900-ab] [0900] - PUT DATA - OK 00
...
tgt:BT typ:1 src:MT [10-210a-0994c0003b08c100000000-cc] [0994c0003b08c100000000] - PUT DATA 003b 000000 (94c0003b08c100000000)
tgt:MT typ:2 src:BT [10-0221-0900-ab] [0900] - PUT DATA - OK 00
...
tgt:BT typ:1 src:MT [10-210a-0994c0003808c100000000-3f] [0994c0003808c100000000] - PUT DATA 0038 000000 (94c0003808c100000000)
tgt:MT typ:2 src:BT [10-0221-0900-ab] [0900] - PUT DATA - OK 00
...
tgt:BT typ:1 src:MT [10-210a-0994c0005b08c100000000-84] [0994c0005b08c100000000] - PUT DATA 005b 000000 (94c0005b08c100000000)
tgt:MT typ:2 src:BT [10-0221-0900-ab] [0900] - PUT DATA - OK 00
...
tgt:BT typ:1 src:MT [10-210a-0994c0004408c100000000-62] [0994c0004408c100000000] - PUT DATA 0044 000000 (94c0004408c100000000)
tgt:MT typ:2 src:BT [10-0221-0900-ab] [0900] - PUT DATA - OK 00

5-10 km/h, not sure how you got a log while riding the bike :)
At this point you really should have had assist, communication looks perfect.

I'm slightly at a loss from here, by the communication log, it should work!
Some thoughts, but all feel wrong:
- This behavior would be normal if the serial does not match. But since the bike worked like this, that seems very unlikely. There is a command to read the serial from the motor though, to make really sure: 10 01 43 08 40 5B 00 A8
- Just to make sure, did you actually get on the bike and pedal to test the Assist? From my early experiments, I found that driving the pedals by hand doesn't usually give enough force to trigger the assist. Might be the same with the back wheel in the air too. Best is to sit on the bike, wheels on the floor, and just pedal :)
- There might still be something off in the calibration, but I don't see how, apparently it's normal for the XHP not to ask the calibration data. You could try to re-calibrate one last time: Have everything connected, after power on maybe press the button once (might not be needed after power on), which should give just one blink, then hold the button long again, till you see 10 fast blinks. Make sure the bike is stood still, and you are not sitting on it, just like in the manual.

Other than that I'm currently out of ideas though :/


Attached are the parsed logs again
 

Anhänge

  • Start 3 blinks.txt
    549,3 KB · Aufrufe: 1
  • before dead.txt
    86,9 KB · Aufrufe: 1
U

Uli2412

Dabei seit
02.04.2022
Beiträge
50
Punkte Reaktionen
5
- Just to make sure, did you actually get on the bike and pedal to test the Assist? From my early experiments, I found that driving the pedals by hand doesn't usually give enough force to trigger the assist. Might be the same with the back wheel in the air too. Best is to sit on the bike, wheels on the floor, and just pedal :)
This was the fault! As I have no "rollentrainer", I tried to pedal with brake for resistance. But you were right (as always :)): With pedaling I had assistance! So a big step forward!
Thank you!
 
V

void-spark

Dabei seit
08.09.2021
Beiträge
222
Punkte Reaktionen
91
This was the fault! As I have no "rollentrainer", I tried to pedal with brake for resistance. But you were right (as always :)): With pedaling I had assistance! So a big step forward!
Thank you!
Great success! :)
It's easy to be right if you've made the same mistakes before :D

Well, you can bike now at least :)
Now it's waiting for me to finish(start) CU3 support I guess :)
 
J

Johny55

Dabei seit
04.05.2022
Beiträge
2
Punkte Reaktionen
0
You guys ( i supose it's all males) do a absolute great job! I am following this topic for quit a while (as lots of others do i supose) but i can't give any help.
In 2020 i wanted to start learing working with development boards. I bought me a STM32 and some other stuff, but so far didn't find the time to start with it. Now with this bicycle project its time to make a second start. I already have the stuff you guys use from Aliexpress, and soon i'll start with it. It's great just to follow what you guys did as a practical project.
Thanks again for all your effords.

Now......while i am here, i do have a question.
Programming ESP32, is that best done with arduino software, or is there a better programm for me, as a newbe?
 
V

void-spark

Dabei seit
08.09.2021
Beiträge
222
Punkte Reaktionen
91
Programming ESP32, is that best done with arduino software, or is there a better programm for me, as a newbe?
How much programming experience do you have, in which environments, if any? :)
If you're a true newbie, for ESP32 I would recommend Arduino IDE with the ESP32 Arduino core, there's so much tutorials and libraries available.
But, if you actually want to compile or work on the code I wrote for the Sparta ION, you must use the Espressif IDF, with a IDE of your choosing.
The IDF is a lot harder for someone with no experience though, besides learning how to code, you also need to to learn how to set up the environment, and you usually have to code at a much lower level, since theres less 'easy' libraries to use, and less tutorials :)
 
J

Johny55

Dabei seit
04.05.2022
Beiträge
2
Punkte Reaktionen
0
Thanks for your reply void-spark.
My experience is 3 years Basic at HTS (netherlands) way back in 1978, and then a bit machine language for a Commodore 64......... :))))
My goal is first to follow your project, and i don't wanna go so far i want to learn programm myselves. So, just programming also maybe other types of small micro computers. Maybe later trying to understand whats going on i a programm would be a nice follow up.
So far i am good equeped with my alieexpres stuff and 4 old sparta bikes to work with.......
 
Hochsitzcola

Hochsitzcola

Themenstarter
Dabei seit
04.09.2009
Beiträge
4.295
Punkte Reaktionen
4.196
Details E-Antrieb
Gazelle mit BionX IGH3 + OpenSource Firmware
V

void-spark

Dabei seit
08.09.2021
Beiträge
222
Punkte Reaktionen
91
Testing with the CU3, learning a lot :)
It asks for a lot of data, found at least the total distance value, battery level % value, and time value.
There are a lot more, but the result are probably hidden in sub menus, so harder to see the effect :)
There is also one command that sets a lot of details of the display, whether it should keep showing the display (or return to logo),
the level icon to show in the upper right (1-3), the speed km/h, a up arrow icon (avg speed), if it should show battery only, or battery + charging screens, and light.
Looks like it sets the assist level / on/off with commands to the BMS, still need to look into those.
Lot of progress though in figuring it out :)
 
L

Lemi4

Dabei seit
26.05.2022
Beiträge
2
Punkte Reaktionen
0
Hallo, Leute. Ich spreche kein Deutsch, also schreibe ich über einen Übersetzer. Ich bin über einen Link aus einem anderen Forum auf dieses Forum gekommen, und von dort über einen Link aus einem anderen Forum.... Ich habe gelesen, was Sie hier tun, und ich verstehe nichts... Überhaupt nichts...

Habe ich richtig verstanden, dass Sie herausgefunden haben, wie man das Gehirn des Sparta-Elektrofahrrads hacken kann, um den Fehler E0003 zu beseitigen?

Wenn ja, kann einer von euch ein Youtube-Video mit einer Anleitung machen??? Es ist also ohne Worte klar, welche Teile man kaufen muss, wie man alles an das Elektrofahrrad und dann an den Computer anschließt und welche Tasten man am Computer drücken muss, um das Fahrrad zu blinken. Können Sie mir bitte helfen???
:cry:
 
V

void-spark

Dabei seit
08.09.2021
Beiträge
222
Punkte Reaktionen
91
Habe ich richtig verstanden, dass Sie herausgefunden haben, wie man das Gehirn des Sparta-Elektrofahrrads hacken kann, um den Fehler E0003 zu beseitigen?
What is your main language? :)

I'll try to give you a short and clear answer:
- No, we do not have a way to solve E0003 errors.

Note that E0003 means your battery has actually gone bad, so there is no simple fix.

The best we can provide here is a relatively 'cheap' way to use any (new or second hand) battery as a replacement for your broken battery, if it is the same voltage.
But, it currently requires quite a lot of technical expertise to do so. It sounds like it is not a good solution for you :)
 
L

Lemi4

Dabei seit
26.05.2022
Beiträge
2
Punkte Reaktionen
0
What is your main language? :)

I'll try to give you a short and clear answer:
- No, we do not have a way to solve E0003 errors.

Note that E0003 means your battery has actually gone bad, so there is no simple fix.

The best we can provide here is a relatively 'cheap' way to use any (new or second hand) battery as a replacement for your broken battery, if it is the same voltage.
But, it currently requires quite a lot of technical expertise to do so. It sounds like it is not a good solution for you :)
Meine Sprache ist Russisch, aber ich lebe in der Ukraine.
Wenn Sie sagen, dass es mir nicht helfen wird, dann okay ... Ich muss nichts erklären ... :cry:
 
Thema:

Zweiter Frühling für ION-Antrieb --- Sparta, Batavus, Koga ...

Zweiter Frühling für ION-Antrieb --- Sparta, Batavus, Koga ... - Ähnliche Themen

Sparta ION Akku defekt?: Hallo zusammen, ich bin neu hier, vielen Dank für die Aufnahme...und ich komme gleich mit einem Problem/Frage. Meine Frau fährt (wenig, da sie...
Sparta Ion, Hercules emove, Batavus, Koga auf Li-Ion Akku umbauen reparieren.: Ich bin Besitzer zweiter solcher Bikes und habe diese nach einem Akkudefekt erfolgreich umgebaut. Gleich vorweg, es ist zeitaufwendig, man sollte...
Sparta M7e ion Antrieb von 2016: Hallo Leute, kurz zu mir: Ich bin seinerzeit mit einem Bausatz aus China angefangen (mit dem ich mich entsetzlich auf die Nase gelegt habe), dann...
verkaufe Koga E-Runner, Rh 47cm, ION-Antrieb, wie neu, super ausgestattet: Schnäppchen: Koga E-Runner, nur EUR 2.050,-/Neupreis EUR 3.000,- muß wg OP leider verkaufen, Fahrrad kaum genutzt, Heck-Motor ION-Antrieb (33 Nm)...
erledigt E-Bike SPARTA Blackline ION mit Garantie: BeschreibungHalle verkaufe hier ein E-Bike von Sparta, Model Black Line kompl. mit Ladegerät. Das E-Bike war ein Ausstellungsstück und hat das...
Oben