Xiaoxiang Smart BMS V3.1 1020/21 mit Rekuperation

Diskutiere Xiaoxiang Smart BMS V3.1 1020/21 mit Rekuperation im Akkus, Batteriemanagement (BMS) und Ladegeräte Forum im Bereich Diskussionen; Hallo zusammen. Ein paar Worte vorab: Für Mein Cube EPO der ersten Generation mit GO SwissDrive Antrieb, Sattelstützenakku und Ant+ Funkverbindung...
E

EPO2012

Themenstarter
Dabei seit
24.07.2020
Beiträge
420
Punkte Reaktionen
186
Ort
88481 Balzheim
Details E-Antrieb
GO SwissDrive, 36V, Sattelstützen akku, Ant+
Hallo zusammen. Ein paar Worte vorab:
Für Mein Cube EPO der ersten Generation mit GO SwissDrive Antrieb, Sattelstützenakku und Ant+ Funkverbindung benötige ich einen neuen Akku.
Da die Umrüstung meines Uralt Akkus mit 8.8Ah nicht funktioniert hat (das BMZ BMS habe ich wohl verärgert - oder es mich?) , besorgte ich mir ein Smart BMS von SZLLT.
Es ist alles provisorisch angeschlossen, Laden und Stromabgabe funktioniert, Android App mit Bluetooth ebenfalls perfekt, selbst die PC App mit UART USB Anschluss funktioniert. (damit können angeblich auch Spannungs-/Stromverläufe aufgezeichnet werden).
Strom kann über die App abgeschaltet werden.
Blöderweise wird der Entladestrom negativ angezeigt UND der Strom entgegen des Uhrzeigersinns angezeigt, siehe Fotos:
Screenshot_20210402_105829_com.jiabaida.bms.jpg

Beim Laden stimmt die Anzeige:
Screenshot_20210402_112250_com.jiabaida.bms.jpg

Trotz vielfältiger Einstellungsmöglichkeiten habe ich keine Anpassung vornehmen können.
Kann mir jemand weiterhelfen?
Screenshot_20210402_112719_com.jiabaida.bms.jpg
 
T

temp

Dabei seit
31.05.2018
Beiträge
470
Punkte Reaktionen
580
Dann würde ich mal die Verkabelung überprüfen. Andererseits wie würdest du den Strom den sonst bezeichnen den du aus dem Akku entnimmst? Positiv ist der nicht. Wenn du es umgedreht haben willst, würdest du mit -3A Laden. Auch nicht schlecht...
Weiterhin auch unbedingt auf den max. Ladestrom achten. Wenn du das falsch einstellst und die Rekuperation geht auch übet die Ladefets, hast du augenblicklich Elektroschrott wenn das BMS die Rekuperation unerwartet abschaltet.
 
Zuletzt bearbeitet:
E

EPO2012

Themenstarter
Dabei seit
24.07.2020
Beiträge
420
Punkte Reaktionen
186
Ort
88481 Balzheim
Details E-Antrieb
GO SwissDrive, 36V, Sattelstützen akku, Ant+
Verkabelung habe ich überprüft, stimmt mit dem Schema überein, das mit dem BMS geliefert wurde:
1617364321644.png


Allerdings habe ich jeweils nur 1 Kabel am BMS angeschlossen (an B- und C-).
Die beiden Lötanschlüsse von B- und C- sind ohnehin auf der Platine verbunden.
Was den Strom anbelangt, der ist Werksseitig auf 30A eingestellt, für Laden und Entladen, siehe Bild:
Screenshot_20210402_134602_com.jiabaida.bms.jpg


Nur das Vorzeichen bei Entladen (40A Überstrom) habe ich von + auf - geändert, der Entladestrom war bereits mit - 30A eingetragen.

Möglicherweise kann dieses BMS in beide Richtungen mit 30A belastet werden?
(Ich konnte 10 Mosfets auf der Platine sehen, 2x5 Anordnung)
 
E

EPO2012

Themenstarter
Dabei seit
24.07.2020
Beiträge
420
Punkte Reaktionen
186
Ort
88481 Balzheim
Details E-Antrieb
GO SwissDrive, 36V, Sattelstützen akku, Ant+
Discharge overcurrent release mit - oder + ändert nichts.
Versuchsweise habe ich die Liontron Software installiert, da funktionieren nur die Menüpunkte 1 und 7 von 7 bei der Xiaoxiang App.
Sieht dann beim Entladen so aus:
Screenshot_20210403_220251_com.jiabaida.LIONTRON.jpg

Und beim Laden so:
Screenshot_20210403_235012_com.jiabaida.LIONTRON.jpg

Also alles richtig verdrahtet, nur ein kleiner Vorzeichenfehler in der Xiaoxiang App🤔
 
T

temp

Dabei seit
31.05.2018
Beiträge
470
Punkte Reaktionen
580
nur ein kleiner Vorzeichenfehler in der Xiaoxiang App
Der Vorzeichenfehler ist ehr in deinem Kopf. Die App zeigt die Verhältnisse aus Sicht des Akkus. Und da ist Entladen nun Mal: der Strom fließt aus dem Akku raus, also -.
Anders herum würde auch keiner auf die Idee kommen dem Ladestrom eines Akkus ein Minuszeichen voran zu stellen. Ausser Dir natürlich.
 
M

MarkusSi

Dabei seit
21.03.2020
Beiträge
1.041
Punkte Reaktionen
1.367
Details E-Antrieb
Stromer ST2 und Diamant s-ped mit BionX Motor
Discharge overcurrent release mit - oder + ändert nichts.
Da -30s einzustellen ist auf jeden Fall falsch.
Bitte auf die Einheit achten, dort stellst du die RücksetzZEIT nach einem Überstrom ein. Default waren 30s. Du hast jetzt -30s draus gemacht. Welche Folgen das bei Überstrom hat, hängt von der Programmierung ab. Im schlechtesten Fall funktioniert die Überstrom Abschaltung nicht.
 
E

EPO2012

Themenstarter
Dabei seit
24.07.2020
Beiträge
420
Punkte Reaktionen
186
Ort
88481 Balzheim
Details E-Antrieb
GO SwissDrive, 36V, Sattelstützen akku, Ant+
Der Vorzeichenfehler ist ehr in deinem Kopf.

Soso. Einfach mal nochmal den Text und die Bilder auf Dich wirken lassen, dann nochmal antworten, darf auch freundlicher sein😉
Hier nochmal (Zitat) :
Blöderweise wird der Entladestrom negativ angezeigt UND der Strom entgegen des Uhrzeigersinns angezeigt, siehe Fotos:
 
E

EPO2012

Themenstarter
Dabei seit
24.07.2020
Beiträge
420
Punkte Reaktionen
186
Ort
88481 Balzheim
Details E-Antrieb
GO SwissDrive, 36V, Sattelstützen akku, Ant+
Da -30s einzustellen ist auf jeden Fall falsch.
Da gebe ich Dir Recht, es bringt nichts, das Vorzeichen zu ändern.

Bitte auf die Einheit achten
Die dürfte falsch sein, sollte discharge overcurrent release in A sein, der Strom Wert, bei dem eine Wiedereinschaltung erfolgt, sofern dieser Strom mindestens für die Dauer der Zeitverzögerung nicht überschritten wird.
Die Zeit (delay) wird darunter eingestellt.
 
M

MarkusSi

Dabei seit
21.03.2020
Beiträge
1.041
Punkte Reaktionen
1.367
Details E-Antrieb
Stromer ST2 und Diamant s-ped mit BionX Motor
Die Zeit (delay) wird darunter eingestellt.
Edit meint, dass du vermutlich recht hast. Daher das vorherige gelöscht, hatte angenommen dass ein Überstrom sofort abgeschaltet wird. Aber dafür gibt's ja noch Hardware Protection.
Dann wird die Einheit wirklich falsch sein. Wenn man A einstellen kann, darf der Strom natürlich auch negativ sein.
Eine Auswirkung der Einstellung -30A vs. 30A hast du natürlich erst, wenn der Overcurrent (-40A) mal ausgelöst wurde.

Die Optik der Anzeige gehen den Uhrzeigersinn ist wirklich Murx. Würde ich dem Entwickler mal um die Ohren hauen.
 
Zuletzt bearbeitet:
E

EPO2012

Themenstarter
Dabei seit
24.07.2020
Beiträge
420
Punkte Reaktionen
186
Ort
88481 Balzheim
Details E-Antrieb
GO SwissDrive, 36V, Sattelstützen akku, Ant+
Also vermutlich kurzzeitige Bestromung und Herantasten an 30A, solange, bis die 30A für die Dauer der unter "delay" eingestellten Zeit erreicht oder unterschritten sind, so stelle ich es mir vor, ob es stimmt weiß ich leider nicht.

Strom - oder + ist wirkungs-(sinn-) los, die Richtung ist durch die Verdrahtung festgelegt, habe jetzt alle Werte positiv eingetragen, im Programm wird evtl. der Betrag verwendet.

Selbst die V3.1 1026 und die V3.1 1015 zeigen gegen den Uhrzeigersinn an.
Die V3.1 004 macht es richtig.
Insgesamt finde ich die App sehr gut gemacht, ein paar Verbesserungen und es gibt nix mehr zu Meckern:
- Passwortschutz fehlt bei mir (neu installieren?)
- Anzeige lässt sich nicht umschalten (Driving/Monitoring Mode)
- "Gegenuhrzeigersinn"
- s statt A

Habe mehrere Supports per Email kontaktiert, warte noch auf Antwort.
 
M

MarkusSi

Dabei seit
21.03.2020
Beiträge
1.041
Punkte Reaktionen
1.367
Details E-Antrieb
Stromer ST2 und Diamant s-ped mit BionX Motor
Also vermutlich kurzzeitige Bestromung und Herantasten an 30A, solange, bis die 30A für die Dauer der unter "delay" eingestellten Zeit erreicht oder unterschritten sind, so stelle ich es mir vor, ob es stimmt weiß ich leider nicht.
Ich verstehe das irgendwie so:
Wenn 40A überschritten werden, startet das Delay. Wenn innerhalb der Delay-Zeit (10s) die 30A unterschritten werden, bleibt das BMS eingeschaltet.
Sonst schaltet das BMS ab.

Moment, dann braucht man doch zwei Zeiten. Irgendwie muss das BMS ja wissen, wann es wieder zuschalten darf. Oder es schaltet erst nach Ladung / entfernen der Last / ... wieder zu. Keine Ahnung.

Vielleicht ist es eher so:
Wenn Discharge overcurrent (40A) überschritten wird, läuft die Zeit Discharge overcurrent release (30s) ab. Wenn der Strom nach dieser Zeit immernoch >40A ist, wird abgeschaltet.
Nach dem Abschalten wird die Zeit Discharge overcurrent release delay (10s) abgewartet, bevor wieder zugeschaltet wird.

Was sagen denn die Fragezeichen? Da gibt es doch vermutlich Erklärungen.

Deine Meinung, dass es egal ist ob dort ein positiver oder negativer Strom konfiguriert wird, teile ich übrigens nicht. Im Zweifel wird die Überstrom-Abschaltung nicht funktionieren, wenn die falsche Polarität eingestellt ist. Dass Beträge verarbeitet werden, glaube ich eher nicht.
 
E

EPO2012

Themenstarter
Dabei seit
24.07.2020
Beiträge
420
Punkte Reaktionen
186
Ort
88481 Balzheim
Details E-Antrieb
GO SwissDrive, 36V, Sattelstützen akku, Ant+
Da war ich wohl auf dem Holzweg....

Die Erklärung unter den Fragezeichen ist folgende:

When the battery pack is discharged, the discharge current exceeds the discharge overcurrent protection value and reaches the discharge overcurrent delay time. The BMS turns off the discharge switch and stops the discharge to prevent super power use.

Vor dem Abschalten beim eingestellten Maximalwert läuft die overcurrent release delay time, z. b. 15s. Danach wird erst abgeschaltet, vermutlich nur, wenn der Strom in dieser Zeitspanne über 40A liegt.

After the discharge overcurrent protection occurs, the BMS re-opens the discharge switch after reaching the discharge overcurrent release time.
z.b. 30s.

Also nach dem Abschalten bei dem eingestellten Maximalstrom und Verstreichen der 30s wird wieder eingeschaltet.

So sollte es passen.

Zum Vorzeichen der Ströme, ich trage nur positive Werte ein, dann sollte es funktionieren.
In der Bezeichnung Ladestrom (+) und Entladestrom (-) ist die Strom Richtung schon vorgegeben.
 
Z

Zerolook

Dabei seit
22.07.2022
Beiträge
37
Punkte Reaktionen
3


Screenshot_20220721-223858.png

Hallo zusammen könnt ihr mir vielleicht weiter helfen was bedeutet der untere Bereich mit 1,2,3,4 in gelb grau und rot, ist die Batterie noch in Ordnung oder was heißt das?
Vielen Dank im voraus
 
T

TaunusEBike

Dabei seit
22.06.2020
Beiträge
1.054
Punkte Reaktionen
476
Das die Zellbänke nicht in balance sind. Bank 4 hat im Gegensatz zu den anderen Bänken eine zu hohe Spannung. Dieser Akku hat irgendwo ein Problem dem man auf die Spur kommen sollte. Insbesondere wenn er eine sehr hohe Kapazität hat, wird man nicht drum herum kommen ihn manuell zu balancen, da ein passiver Balancer dafür zu schwach ist.
 
Z

Zerolook

Dabei seit
22.07.2022
Beiträge
37
Punkte Reaktionen
3
Danke für die schnelle Antwort, Kann man die über die App vielleicht Kaliberen oder wie kann man das am besten machen?
 
T

TaunusEBike

Dabei seit
22.06.2020
Beiträge
1.054
Punkte Reaktionen
476
Das hat nichts mit der App zu tun. Entweder ist eine oder mehrere Zellen defekt, es wurde beim Bau gepfuscht, oder es haben sich Zellen gelöst. Wenn du den Akku neu gekauft hast, dann würde ich mich an den Händler wenden. Leider verschweigst du uns wie viel Kapazität der Akku hat. Bei geringer Kapazität kann das BMS es ausbalancieren.
 
Z

Zerolook

Dabei seit
22.07.2022
Beiträge
37
Punkte Reaktionen
3
Ja stimmt mein Fehler, das hatte ich verschwiegen der Akku hat eine Kapazität von 100ah. Leider über eBay Kleinanzeigen gekauft.
 
T

TaunusEBike

Dabei seit
22.06.2020
Beiträge
1.054
Punkte Reaktionen
476
Kannst ja alles im Auge behalten und eventuell mal mit einem Labornetzteil von Hand es etwas in balance bringen. Wenn die Differenzen höher werden auf Dauer, dann muss man mal genau überprüfen wo das Problem ist.
 
Z

Zerolook

Dabei seit
22.07.2022
Beiträge
37
Punkte Reaktionen
3
Labornetzteil? Woher nehmen wenn nicht stehlen. Bin ja nur ein leihe in diesem Thema
 
T

TaunusEBike

Dabei seit
22.06.2020
Beiträge
1.054
Punkte Reaktionen
476
Vielleicht kann ein Lifepo4 Profi dazu mehr sagen. Nur generell haben Lifepo4 einen höheren drift. Du hast gut 100A und vermutlich einen reinen passiven Balancer. Dieser kann nur mit geringen Strömen balancen.

Wenn es dich nicht stört das du weniger Kapazität entnehmen kannst, würde ich alles so lassen. Sollte der drift größer werden, würde ich mal zum Experten gehen, davon haben wir viele in der Gruppe, und den Akku untersuchen lassen.
 
Thema:

Xiaoxiang Smart BMS V3.1 1020/21 mit Rekuperation

Oben