VESC Eigenbau Problem

Diskutiere VESC Eigenbau Problem im Controller/Regler, Fahrerinformation, Elektronik Forum im Bereich Diskussionen; Eingestellte Totzeit ist 360ns... Das passte auch immer mit den gemessenen Werten

CTSchorsch

Dabei seit
02.02.2018
Beiträge
388
Eingestellte Totzeit ist 360ns...
Das passte auch immer mit den gemessenen Werten
 

CTSchorsch

Dabei seit
02.02.2018
Beiträge
388
Hier mal ein kleines Update:

Die Schottkys waren eindeutig an der falschen Stelle :) Hier mal der Stand so wie auf dem Foto:

tek00011.png

tek00013.png


Deutliche Peaks ins Negative. Ich habe dann auf Hinweis aus dem VESC Forum mal die Schottkys hin zum Treiber geschoben und zusätzlich noch ein kleines C (10nF) an allen FETs von G nach S gelegt. In meinen Augen jetzt deutlich besser:

tek00000.png


tek00001.png
 

tecnologic

Dabei seit
15.08.2018
Beiträge
420
Ort
Bargteheide bei Hamburg
Details E-Antrieb
UNIMOC 4850 an Bafang G310
Deutliche Peaks ins Negative. Ich habe dann auf Hinweis aus dem VESC Forum mal die Schottkys hin zum Treiber geschoben und zusätzlich noch ein kleines C (10nF) an allen FETs von G nach S gelegt. In meinen Augen jetzt deutlich besser:
Schottkys hin zum Treiber?

Die 10nF am Gate erhöhen dir natürlich die Gatekapazität. Was du noch Probieren könntest wäre 100pf oder so vom Drain zum Source als sog. Millerkapazität einzusetzen. Die verlängert das Miller Plateau also der Zeitpunkt in der Einschaltkurve des Gates wenn die Vgs > Vth wird. Das begrenzt den Stromanstieg effektiver als die Gate Kapazität. Dann solltest du aber deine Gate Widerstände kleine halten. Weil der Cap sonst zu einem false turn on führen kann.
 

CTSchorsch

Dabei seit
02.02.2018
Beiträge
388
Die Schottkys näher am Treiber platziert. Bisher hatte ich die in FET Nähe

Ja, ich habe mit deinem Einspruch der GateKapazität gerechnet :) Ich messe gleich mal ohne. Vermute dass es nicht viel ausmacht

G
 

CTSchorsch

Dabei seit
02.02.2018
Beiträge
388
Und ohne siehts auch nich schlecht, wenn nicht sogar besser aus :) Musste jetzt auf 40ns aufziehen um überhaupt noch was zu sehen

tek00002.png


Gerade bei der fallenden Flanke ist deutlich weniger Klingeln drauf

tek00003.png
 

tecnologic

Dabei seit
15.08.2018
Beiträge
420
Ort
Bargteheide bei Hamburg
Details E-Antrieb
UNIMOC 4850 an Bafang G310
Das ist jetzt nur die Schottky?

Das bestätigt aber auch meine Erfahrung mit externer Gatekapazität. Die Verbindung vom Gate zum externen Cap neigt zum Schwingen was an der Stelle nie gut ist.

Ich würde das erstmal so lassen. Bis du es wieder kaputt getestet hast :ROFLMAO:
 

CTSchorsch

Dabei seit
02.02.2018
Beiträge
388
5R6 in Reihe, dann Schottky gegen GND, dann PIN vom IC.
Ja, so gefällt mir das auch
 

tecnologic

Dabei seit
15.08.2018
Beiträge
420
Ort
Bargteheide bei Hamburg
Details E-Antrieb
UNIMOC 4850 an Bafang G310
5R6 in Reihe, dann Schottky gegen GND, dann PIN vom IC.
Ja, so gefällt mir das auch
Also Phase mit 5R6 an den Treiber und am Treiber mit Diode den undershoot geblockt, macht sind. Das überlebt die Diode und der Treiber. Wenn die 5R6 als zusätzlicher GateWiderstand in der HS nicht stören würde ich das so lassen.
 

CTSchorsch

Dabei seit
02.02.2018
Beiträge
388
Soo, ging dann doch schneller als gedacht :)

Da der Motor immer so viel Krach macht, wenn ich den mit foc_openloop bestrome, habe ich den Rotor abgemacht und nur die Spulen bestromt. Da ich ja im openloop bin, sollte das egal sein. Ich wollte hauptsächlich Strom durch die Platine jagen. Da war dann nach einigen Tests ohne Probleme auf einmal mittendrin schluß... Bei 20A Motorstrom.

Der Treiber ist diesmal aber ganz geblieben. Zumindest was ich stromlos, messtechnisch messen kann. Beide FETs einer Phase sind aber durch. Und das bei einer im Netzteil eingestellten Strombegrenzug von 10A. Da können die also nicht wirklich einen Hitzetod gestorben sein. Was kann denn sonst noch so passieren ? Überspannung am Gate ?
 

CTSchorsch

Dabei seit
02.02.2018
Beiträge
388
Unabhängig von dem ganzen Messen auf dem Tisch, war ich mit einer zweiten Platine und Scooter heute mal im Wasser :) Die Platine hat im oberen Duty-Bereich irgendwann runtergeregelt. Das ist ja erst mal gut. Was mir wohl aufgefallen ist, ist der schnelle Temperaturanstieg:

1614107565190.png

Da stimmt doch was mit der Anbindung an das Alu nicht, oder ? sonst würde das nie so flott wieder abkühlen...

Habe dann die Platine doch noch mal gemessen, weil ich jetzt gar nicht weiß, wie die Risetime mit dem aktuellen Transistor und dem zusätzlichen R in der HS Leitung ist. Und ich muss sagen, ich bin schwer überrascht gewesen:

tek00002.png


Das sind, wenn ich mich nicht verrechnet habe über 2kv / uS. Das ist arg schnell oder ? Ist der BSC070N so flotter als der TPH2R506 ?
Der LM5701 kommt damit gut klar, dem reicht <50V/nS, beim INA bin ich mir gerade nicht sicher...

Ich habe zur Kontrolle noch mal die Deadtime nachgemessen, da ist aber alles wie erwartet

tek00000.png
 

tecnologic

Dabei seit
15.08.2018
Beiträge
420
Ort
Bargteheide bei Hamburg
Details E-Antrieb
UNIMOC 4850 an Bafang G310
Zu den geschossenen FETs: wahrscheinlich ist es eine Überspannung ob Uds oder Ugs ist ist schwer zu sagen. Aber ich vermute um das zu messen brauchst du einen 500MHz diff tastkopf. Am besten kannst du mit 18V TVS Dioden am Gate eine Ugs Überspannung ausschließen.

Zur Temperatur: was ist jetzt anders als vorher bei der Anbindung? Wie war die thermische Strecke Alu - Fet vorher und jetzt?
 

CTSchorsch

Dabei seit
02.02.2018
Beiträge
388
TDP1000, 1GHz diff. Tastkopf ist dran :)
Okay, also warten auf die TVS :) Sind bestellt. Dann beide Gate Anschlüsse absichern ? Am besten direkt am GatePin oder ?
Wenn ich Uds absichern will, ne TVS am FET zwischen D und S an jedem FET ? oder kann ich da was zusammenfassen ?

"Eigentlich" ist nichts anders. Platine liegt über ein dünnes Gap-Pad direkt auf dem Alu. Allerdings habe ich das Gefühl das dass PCB nicht richtig angedrückt wird...Vielleicht fülle ich auch mal etwas mehr Zinn in die Vias

Was meinst du zur Rise-Time ? Runterbringen und Umschlatverluste in Kauf nehmen ? die BSC haben leider eh schon ca. doppelten Rdson
 

tecnologic

Dabei seit
15.08.2018
Beiträge
420
Ort
Bargteheide bei Hamburg
Details E-Antrieb
UNIMOC 4850 an Bafang G310
Die Rose Time würde ich schon runter bringen wollen.

TVS an jedem Gate direkt und TVS auf der Phase gegen gnd direkt an den FETs muss reichen.
 

CTSchorsch

Dabei seit
02.02.2018
Beiträge
388
Ja, ich werde wohl nicht um die TVS rumkommen. Ich komme hier auf keinen grünen Zweig. Spricht was dagegen die Treiber näher an die FETs zu bringen ?
 

CTSchorsch

Dabei seit
02.02.2018
Beiträge
388
Okay, ich habe auch mal nach anderen Treibern gesucht. Kennst du den aus dem Anhang ? Der hat, wenn ich das richtig gesehen habe, schon eingebaute Schutzdioden. Ich bin mir allerdings nicht sicher ob der Strom für die Gates reicht...
 

Anhänge

  • Infineon-2ED2304S06F-DataSheet-v02_06-EN.pdf
    1,1 MB · Aufrufe: 4
Thema:

VESC Eigenbau Problem

VESC Eigenbau Problem - Ähnliche Themen

Einfacher PV-Lader für E-Bike-Akku und Fahrzeugakku 12/24/36V: Die Grundidee war mit einem kleineren Solarmodul 50x50cm ( die Dinger sind ja schwer und unhandlich) in den Bergen oder abgelegenen Gegenden...
Ultramotor a2b Hybrid BMS mit OZ890 defekt oder Sleep mode?: Hallo, bräuchte ein paar Fehlersuch-Ideen... Bin jetzt 5 Jahre problemlos mit dem jetzt defekten original und dazu parallel angeschlossenem...
Oben