Tester unseres MPe Computer / Controller

Diskutiere Tester unseres MPe Computer / Controller im Controller/Regler, Fahrerinformation, Elektronik Forum im Bereich Diskussionen; @marci: Das schaut ja schon mal ganz gut aus ! (y) Nachdem Anna mir bezüglich einer Fehlkonfiguration des Stromsensors weitergeholfen hat und...

HolgiB

Dabei seit
05.01.2020
Beiträge
416
@marci: Das schaut ja schon mal ganz gut aus ! (y)

Nachdem Anna mir bezüglich einer Fehlkonfiguration des Stromsensors weitergeholfen hat und ich auch endlich rausgefunden hab, dass mein zuerst verbauter Speedsensor kein sauberes Signal gegeben hat, konnte ich nun nach Tausch des betroffenen Sensors endlich mal ne Proberunde drehen. Bei mir scheint aber noch ein bisschen der Wurm in den PID Parametern zu stecken, da die Unterstützung super sogar inklusive PAS Boost funktioniert, aber leider nur bis so 18-20 km/h. Danach dreht der MPe die Unterstützung massiv runter, obwohl ich 27 km/h konfiguriert habe. Ich hab auf dem Handy mal eine Bildschirmaufnahme gemacht, bei Youtube hochgeladen und Anna angeschrieben. Ist in der Summe aber so ähnlich wie wenn man das erste Mal nen CA in den Fingern hat. Da geht auch nicht alles sofort.

Bei der Programmierung über Bluetooth braucht man ein bisschen Geduld, aber gefällt mir immer noch besser als die Programmierung des CAs. Auch ist natürlich die Anzeige per App etwas träger als beim CA, der die Messwerte quasi direkt in Echtzeit anzeigt, aber das ist nicht kriegsentscheidend, da man ja ohnehin auf der Tour eher nur an den konstanten Werten interessiert ist. Für Echtzeit bleibt noch das OLED.

Mein Smartphone säuft unter den aktuellen Bedingungen (halt sehr kühl) bei aktiviertem Display plus Bluetooth plus MPe App soviel Strom, dass Ruckzuck der Akku alle ist. Die komischen galvanisch getrennten Stepdown USB-Buchsen von Ali scheinen nur 1 Amp zu liefern, weswegen mein Smartphone halt nach 30-45 Minuten leer ist und ausgeht. Da werde ich noch nachjustieren müssen und ne 2-3 Amp USB-Lademöglichkeit schaffen.
 

marci

Dabei seit
12.03.2011
Beiträge
2.493
Ort
82362 Weilheim i.Obb.
Details E-Antrieb
GMAC / Puma und Fatbike Bafang Heckantrieb
Dank Dir :) ist vielleicht Dein Gasgriff out mit 3,5V max (Parameter 14 ( TotMax) (80) vielleicht zu wenig für vollgas bei Deinem Controller?
Hast Du mit GPS gemessen? Habe den Speedsensor bei mir im Motor erst einmal rudimentär angegeglichen (Parameter 27), über die fest eingestellte Schiebehilfe vom LCD3.. Ob das auch stimmt, werde ich sehen, wenn ich die nächste Probefahrt mache und mein Garmin finde ;-)
 
Zuletzt bearbeitet:

HolgiB

Dabei seit
05.01.2020
Beiträge
416
Moin @marci
Nein, mein Gasgriff Ausgang am MPe gibt genug Dampf weil ich bei meiner höchsten Unterstützungsstufe die PAS Boost Werte auf nahe der Maximalleistung (~ 600W) gestellt habe und ich beim Anfahren auch 540-560W sehe. Dementsprechend sollte das passen ;)

Was die Geschwindigkeit betrifft, so muss man das als passionierter Radler doch nicht messen. Man hat doch ein gutes Gefühl dafür wie schnell man unterwegs ist, oder ?
Ich merke ja auch ohne Tacho ob meine Durchschnittsgeschwindigkeit irgendwo bei 15-16 km/h rumdümpelt, oder ich oberhalb der 22 km/h liege. Genauso für 15 versus 20 versus >= 25 km/h. Da brauche ich weder GPS noch Tacho dafür :)

So gesehen ist die Geschwindigkeit am MPe schon recht realistisch.
 

HolgiB

Dabei seit
05.01.2020
Beiträge
416
So, nach kurzem Mailaustausch mit Anna habe ich eben nach dem Abendessen mal die PID-Werte für die PAS Regelung verdoppelt.

Vorher:
1606764269476.jpg

Nachher:
1606764269468.jpg

Und siehe da ! Es lebt :LOL:

Steht übrigens auch in Kapitel 9.3.5 der Anleitung.
Wenn der Holgi nur mal immer die Anleitung lesen würde. :censored:

Ich bin jetzt unschlüssig ob die PID-Regelung in meinem Fall einfach zu stark gedämpft war oder generell zu schwach eingestellt. Ich hab vorhin mal die Anleitung zur Optimierung der Gain-Parameter am CA gewälzt und danach müssten sowohl der P-Wert als auch der I-Wert deutlich zu niedrig eingestellt gewesen sein.

Nun gut, aber zumindest eben beim Anfahren im Hof merkte ich im limitierten Modus (250W/25 km/h) einen deutlichen Anschub wie ich das beispielsweise auch von der CA-Regelung gewohnt bin. Das war gestern bei der Rundfahrt im Wald deutlich softer mit weniger Unterstützung.

Leider sind die Temperaturen und die frühe Dunkelheit nicht gerade so die großen Motivatoren noch ne Proberunde zu drehen.
 

HolgiB

Dabei seit
05.01.2020
Beiträge
416
Ich bin heute mit dem Rad zur Arbeit gefahren und bis knapp um die 20 km/h fühlte sich von der Unterstützung her alles ok an. Der MPe tat gefühlt was er sollte. Tja, nur eben nicht bis 25 bzw. 27 km/h. Oberhalb von 20 km/h kam keine Leistung mehr. Das gab mir heute keine Ruhe und ich hab noch ein bisschen gegrübelt, was da mit reinspielen könnte. Der Brückenstecker am KT36 Controller für reduzierte Geschwindigkeit (weiß / einpolig) war nicht gesteckt.

Gut also zu Hause mal den MPe vom Gaseingang des Controllers abgezogen und testweise einen Gasgriff angesteckt.....und siehe da: Gleiches Problem wie beim MPe: Nur Unterstützung bis 22 km/h. :rolleyes:

Also hab ich kurzerhand ein loses KT LCD8S anstelle des Displaybrückensteckers angesteckt und mir mal die Konfiguration angeschaut (wobei ich mir nicht sicher bin, was im Controller gespeichert ist und was im Display).

Das war die Grundeinstellung:
1606926531451.jpg


Was mir ins Auge sprang waren die 27 km/h. Die hab ich dann mal gleich auf 72 km/h gestellt um zu vermeiden, dass irgendwie das Speedlimit im Controller dem MPe reinfuscht. So, um mit dem Gasgriff ohne PAS testen zu können (weil PAS klemmt ja am MPe) hab ich kurzerhand P4 auf 0 gestellt. Damit lief der Motor auch wieder gefühlt mit angezogener Handbremse. OK, dann fiel mir die Stromreduktion bei C5 ein, wobei ein Wert von 3 der Halbierung des Maximalstroms entspricht (wenn ich die Anleitung richtig deute). Tja, C5 auf 10 (= volle Pulle) und dann am Gasgriff gedreht.

Ergebnis: Der Motor ging ab wie die Wutz......40 km/h im Leerlauf. Also alles abgezogen, Displaystecker drauf, MPe an den Gaseingang anklemmt.

Tja, was soll ich sagen: Der MPe zieht in allen Stufen sauber bis auf über 25 km/h durch und regelt dann ab.

Was mir völlig unklar ist:
- Wenn die Leistungsreduktion nicht nur im Display gespeichert war (das war vorher an meinem alten KT36 22 Amps Controller verbaut, wo der Puma Kommutierungsprobleme hatte), warum unterstützte der MPe dann unter 20 km/h durchaus mit 300-400 Watt ? Und vor Allem was hat die Leistungsreduktion mit der Geschwindigkeit zu tun ?

- Wenn das Speedlimit auf 27 km/h bei ner 28" Laufradgröße war, wieso regelte der Controller bei 20 km/h bereits ab ? Eigentlich kann ein KT Controller ja auch ohne Speedsensor und Hallsensoren die Geschwindigkeit anzeigen solange der Motor unterstützt ?

- Wenn der Gasgriff eigentlich nicht freigeschaltet war ohne PAS wie konnte der MPe dann den Controller ansteuern ohne angeklemmte PAS-Scheibe ?

Alles ganz merkwürdig und mir ist völlig unklar war im Controller sonst dauerhaft gespeichert ist, wenn man nur nen Brückenstecker oder ein LED Bedienteil anklemmt. Weiß das einer ?

Was den verwendeten sensorlosen KT36 14 Amp-Controller meines MPe Bikes betrifft, so bezweifele ich das der jemals groß parametrisiert Geschweige denn verbaut war. Das ist wenn ich mich recht entsinne nur ne Ersatzteilbestellung bei PSWPower gewesen und bestenfalls hing da mal ein Motor im Testbetrieb per Daumengas dran.

Vielen Dank nochmal an Anna für die geduldige Beantwortung meiner Fragen ! (y)
 

marci

Dabei seit
12.03.2011
Beiträge
2.493
Ort
82362 Weilheim i.Obb.
Details E-Antrieb
GMAC / Puma und Fatbike Bafang Heckantrieb
Hihi, ist ja lustig, ich hatte genau deswegen mit meinem neuen KT Controller (Siehe ein paar Beiträge zuvor) erst mal eruiert, was die Unterschiede sind, mit Display und ohne Display zu fahren und war dann auch verwundert, das einiges der Parametrisierung - die zuvor z.B. über ein Display vorgenommen wurden - auch im Controller gespeichert bleiben.
Erkenntnis also:
Erst mal den Controller auf unlimited über das Display parametrisieren und:

.. theoretisch...
.hat man(n) mehrere Displays mit unterschiedlichen Konfigurationen (Ich LCD3 und LCD4), könnte man so auch "verschiedene Profile" fahren, indem man einfach die Displays umschaltbar macht....
;-)
 

HolgiB

Dabei seit
05.01.2020
Beiträge
416
Hihi, ist ja lustig, ich hatte genau deswegen mit meinem neuen KT Controller (Siehe ein paar Beiträge zuvor) erst mal eruiert, was die Unterschiede sind, mit Display und ohne Display zu fahren und war dann auch verwundert, das einiges der Parametrisierung - die zuvor z.B. über ein Display vorgenommen wurden - auch im Controller gespeichert bleiben.

Japp, das mit deinem Controller hatte ich grob überflogen aber nicht so unmittelbar auf mein Problem bezogen. 🤭
Erkenntnis also:
Erst mal den Controller auf unlimited über das Display parametrisieren und:
Tja, so schaut es wohl aus. Wobei es gemäß dem Motto "Jede Messung beeinflusst das Experiment" für mich aktuell nur schwer nachvollziehbar ist, was ursprünglich im Controller gespeichert war, weil ich nicht zuordnen kann was im Konfigurationsmenü des LCD im Controller gespeichert ist und was im Display. Falls überhaupt aus dem Controller gelesen wird. Vielleicht schreibt das Display auch nur seine Werte ohne Rücksicht auf die aktuelle Controller Config.

Fragen über Fragen, die vermutlich nie beantwortet werden. Es sei denn jemand mit Controller Firmware Kenntnissen äußert sich dazu....:LOL:

Fakt ist für mich auf alle Fälle, dass der Controller ja einen aktivierten Gaseingang ohne Leistungsreduktion hatte. Zumindest bis 20 km/h. 🤪

Bleibt als logische Erklärung eigentlich nur, dass im Controller irgendwie ein Geschwindigkeitslimit um die 20 km/h programmiert war. Anders macht es keinen Sinn. Mich ärgert nur, dass mir Fröhn nicht die vergleichsweise langsame Motorgeschwindigkeit bei aufgehängtem Bike nur mit Gasgriff aufgefallen ist. Zwischen 22 und 40 km/h im Leerlauf ist dann noch noch ein kleiner Unterschied. 🤬

Die Fahrt zur Arbeit heute Morgen hat auf alle Fälle voll Bock gemacht. Das Ding beschleunigt wie Wutz. Für die Stadt werde ich aber zumindest in den niedrigeren Stufen die Leistung für PAS Boost etwas runterdrehen und auch die Anfahrrampe etwas sanfter gestalten. Die höheren Leistungsstufen können für die sumpfigen Trail und Anfahren am Berg ja gerne ne steile Rampe haben.

Jetzt fehlt nur noch ein bisschen Zeit und vernünftiges Wetter zum ausgiebigen Testen und Feinjustieren.
 

bikel.pl

gewerblich
Dabei seit
19.05.2019
Beiträge
13
Ort
Polen
Details E-Antrieb
Nine Contonent 7x9, Sabvoton MINI 45A, 72V / TSDZ2
Wenn ich das richtig verstehe, waren alle Probleme gut gelöst und die Probleme waren nicht von der MPe-Seite, sondern von der Seite der KT Controller 👍.

- Wenn die Leistungsreduktion nicht nur im Display gespeichert war (das war vorher an meinem alten KT36 22 Amps Controller verbaut, wo der Puma Kommutierungsprobleme hatte), warum unterstützte der MPe dann unter 20 km/h durchaus mit 300-400 Watt ? Und vor Allem was hat die Leistungsreduktion mit der Geschwindigkeit zu tun ?
Wenn der Controller die Leistung oder Geschwindigkeit begrenzt, kann hier MPe nichts dabei helfen.
Ja, der Controller speichert die Daten nach dem Ausschalten, was in den P- und C-Parametern usw. auf dem Display eingestellt wurde.

Wir empfehlen immer (wie in der Bedienungsanleitung steht 🤭), zuerst das Fahrrad am Controller selbst zu starten und dann den MPe-Computer anzuschließen. Dann haben wir mehr Sicherheit und Kontrolle über den korrekten Funktionieren des Fahrrads.

Wenn es weiterhin Probleme gibt, sage mir bitte Bescheid. Wir werden versuchen immer zu helfen 🙂.
 

HolgiB

Dabei seit
05.01.2020
Beiträge
416
Wenn ich das richtig verstehe, waren alle Probleme gut gelöst und die Probleme waren nicht von der MPe-Seite, sondern von der Seite der KT Controller 👍.
Ja, die Problem waren seitens meines KT Controllers.

Wir empfehlen immer (wie in der Bedienungsanleitung steht 🤭), zuerst das Fahrrad am Controller selbst zu starten und dann den MPe-Computer anzuschließen. Dann haben wir mehr Sicherheit und Kontrolle über den korrekten Funktionieren des Fahrrads.
Korrekt, aber zugegebenermaßen wird es schwierig die Leerlaufdrehzahl des Motors einzuschätzen, wenn man keinen Tacho angeklemmt hat 🤭

Beim initialen Test ohne MPe am Controller nur per Gasgriff drehte der Motor ja....aber eben nur mit 22 km/h. Das ist mir nicht so bewusst aufgefallen.

Wenn es weiterhin Probleme gibt, sage mir bitte Bescheid. Wir werden versuchen immer zu helfen 🙂.
Ja, danke....aber ich hoffe mal, dass ich endlich mal Erfolg zu vermelden habe und mich nicht mit komischen Problemen melde. :rolleyes:
 

BikeAlex

Dabei seit
11.08.2014
Beiträge
1.066
Ort
Ingolstadt
Details E-Antrieb
Q128C, Phaserunner, CA-V3.12, 12s7p LG MH1,
Ich bin zwar von meinem Cycle Analyst begeistert was den Funktionsumfang angeht, aber das Ding ist mehr als nicht mehr zeitgemäß. Auch rechne ich es Justin hoch an dass das System so lange lebt und gepflegt wird. Aber irgend wann einmal ist es einfach Mal gut. Der MPe hat schon einiges was ich am CA vermisse und macht echt einen guten Eindruck. Da ich den Preis als Set absolut Ok finde werde ich es ausprobieren, aber wann kann ich noch nicht sagen. Ich bin gespannt wie das mit dem Phaserunner funktionieren wird.

Grüße
Alex
 

HolgiB

Dabei seit
05.01.2020
Beiträge
416
@BikeAlex: Mir fehlt zwar noch etwas mehr Praxis-Erfahrung mit dem MPe auf Tour, aber als Fahrer von zwei Bikes mit Cycle Anaylst ist der MPe durchaus eine interessante Alternative. Gerade die Kopplung an das Smartphone per Bluetooth für Programmierung und Infos finde ich genial. Wäre schön wenn der CA in kommenden Generationen auch sowas bietet.

Preislich denke ich auch, dass der MPe klar geht, denn man liegt auf gleichem Level wie mit dem CA plus zusätzlichen Komponenten (Poti, Tastersatellit, PAS). In Zeiten wo ich immer häufiger mit Komoot meine Routen fahre / tracke ist gefühlt der CA immer ein bisschen im Weg, weil zumindest bei mir der Lenker am E-Bike gefühlt nie genug Platz hat (USB-Ladebuchse, Klingel, Tastersatellit, Schalter für Beleuchtung, usw).

Da passt der MPe mit dem BT Modul super ins Konzept. Wen das OLED stört, der kann auch einfach einen Tastersatelliten an den MPe anklemmen um die Stufen zu wählen. Ob mir die fünf frei programmierbaren Unterstützungsstufen in der Praxis genügen werden oder ich meine stufenlose Leistungsverstellung von meinen CA Bike vermissen werde kann ich erst nach ein paar ausgiebigen Touren sagen. Also vermutlich eher im Frühjahr. Das PAS Boost Konzept ist durchaus interessant dadurch dass man für jede Stufe eigene Leistungsrampen programmieren kann.

Für Motoren mit Tempsensor wie dem Puma würde ich mir beim MPe aber auch eine Leistungsreduktion wie beim Cycle Analyst und keinen harten Shutdown des Systems wünschen. Zusammen mit meinem 12 FET Controller von EBS kriege ich meinen 16T Puma im Gelände schon regelmäßig mal an die Abriegeltemperatur.

Mit nem Phaserunner sollte der MPe genauso gut zusammenspielen wie mit einem CA. Nachdem meine bescheuerten Controllerprobleme beseitigt sind, fühlt sich der MPe beim Anfahren und der Abriegelung an der Geschwindigkeitsgrenze genauso soft an wie der CA. Sprich: Die PID Regelung gibt sich nicht viel.
 

BikeAlex

Dabei seit
11.08.2014
Beiträge
1.066
Ort
Ingolstadt
Details E-Antrieb
Q128C, Phaserunner, CA-V3.12, 12s7p LG MH1,
Eine Frage habe ich jetzt doch noch. Kann man den MPe so einstellen das er mit dem PAS z.B. eine Geschwindigkeitsbegrenzung mit dem Wert X hat, aber sobald man den Gasgriff betätigt mehr Leistung hat und das die Geschwindigkeitsbegrenzung ignoriert wird und man schneller fahren kann nur so lange man ihn betätigt?

Grüße
Alex
 

bikel.pl

gewerblich
Dabei seit
19.05.2019
Beiträge
13
Ort
Polen
Details E-Antrieb
Nine Contonent 7x9, Sabvoton MINI 45A, 72V / TSDZ2
Eine Frage habe ich jetzt doch noch. Kann man den MPe so einstellen das er mit dem PAS z.B. eine Geschwindigkeitsbegrenzung mit dem Wert X hat, aber sobald man den Gasgriff betätigt mehr Leistung hat und das die Geschwindigkeitsbegrenzung ignoriert wird und man schneller fahren kann nur so lange man ihn betätigt?

Grüße
Alex
Gute Frage 👍. MPe kann leider nicht so eingestellt werden.Wenn du den Gasgriff betätigen, reagiert das MPe-Pedal daher nicht mehr.
Das sieht so momentan aus. Wir werden jedoch an der Entwicklung von MPe arbeiten, damit es in Zukunft solche Funktionen gibt.
LG
Anna
 

marci

Dabei seit
12.03.2011
Beiträge
2.493
Ort
82362 Weilheim i.Obb.
Details E-Antrieb
GMAC / Puma und Fatbike Bafang Heckantrieb
Hallo Leute,
ich muss leider das testen mit dem super MPe Vorcontroller aufgeben, meine familiären Umstände lassen es seit Wochen nicht mehr zu an meinen Ebikes zu schrauben, bzw. zu tüfteln und das wird wahrscheinlich bis Anfang Sommer auch so bleiben.

Darum suche ich einen würdigen Nachfolger, der meinen quasi ungenutzten MPe mit OLED Display, Programmierkabel und Bluetooth Modul übernehmen möchte. Voraussetzung ist, sich damit aktiv zu beschäftigen, hier seine Erfahrungen mit ein paar Bildern einzubringen und am Schluss ein kleines Video zu drehen, wo Du Deinen Umbau mit dem MPe kurz vorstellst :)
Wenn Du zufälligerweise auch noch ein Fahrrad mit 100mm Tretlagergehäuse hast, leg ich Dir auch noch kostenlos ein neues Erider T9 Tretlager mit Sensorik mit Kurbeln und Kettenblatt dazu. (Drehmomentsensor, kann anstatt PAS Sensor genutzt werden)

Danke Anna für den immer netten Kontakt, die tolle Unterstützung und das offene Ohr :)
 

bikel.pl

gewerblich
Dabei seit
19.05.2019
Beiträge
13
Ort
Polen
Details E-Antrieb
Nine Contonent 7x9, Sabvoton MINI 45A, 72V / TSDZ2
Danke Anna für den immer netten Kontakt, die tolle Unterstützung und das offene Ohr :)
Immer gern, Marcel :)
Eigentlich sehr schade, dass du mit MPe durch familiäre Umstände nicht schaffst. Zukünftig sind wir immer offen, damit du den MPe ausprobierst. Bestimmt meldet sich jemand, deinen MPe Computer von Dir zu erhalten.
LG
Anna
 

HolgiB

Dabei seit
05.01.2020
Beiträge
416
Falls derjenige, der Marcis MPe übernimmt Fragen hat, kann er mich gern per PM oder hier im Thread kontaktieren wenn Fragen sind. :cool:

Kurzes Update noch meinerseits: Nachdem ich trotz korrekter Programmierung und "entfesseltem" Controller immer noch merkwürdige Aussetzer in der Unterstützung im PAS-Sensor hatte, konnte ich inzwischen meinen zweiten Austauschspeedsensor und / oder die fiddelige Zuleitung als Fehlerquelle herausfinden. Obwohl der MPe bzw. das OLED Display eigentlich während der Fahrt realistische Werte anzeigten, brach die Leistung stellenweise weg. Nachdem ich dann irgendwelche Bogusgeschwindigkeiten sehen konnte (60+ km/h) obwohl ich quasi nur mit 15-20 km/h unterwegs war, habe ich gestern mal meine Motorverkabelung gehändert und den internen Speedsensor des Motors angezapft:
1607779796262.jpg

Und siehe da: Die Leistungseinbrüche sind weg. Mein Tipp wäre also entweder wirklich den Speedsensor eines Motors, ggf. den Hallsensor eines DDs oder zumindest einen der üblichen Hall-basierten Speedsensor verwenden. Die lassen sich ja stressfrei vom Controller speisen und nur der Speedausgang zum MPe weiterlegen.

Was mir bis dato auch noch aufgefallen ist, aber das mag durchaus Smartphone-abhängig sein:
Die App zum Konfigurieren der Werte reagiert in der Kopplung per Bluetooth sehr instabil, wenn man gleichzeitig einen Bluetooth-Kopfhörer nutzt. Ich hab auf alle Fälle heute während des Musikhören massive Probleme bei Lesen und Setzen von Parametern bis ich endlich die Trennung zum Kopfhörer unterbrochen hab. Ohnehin scheint die Anzeige App etwas verzeihlicher zu sein als die Programmierapp. Ich bekomme zumindest fast immer innerhalb von 10 Sekunden eine Kopplung der Anzeigeapp zum MPe ohne etwas zu tun. Bei der Konfigurationsapp hingegen muss ich fast immer explizit den MPe aus den konfigurierten Bluetooth-Geräten wählen. Manchmal sogar zwei, drei Mal. Ist aber auch nicht so kriegsentscheidend, weil man ja nicht ständig konfiguriert. Beim Setzen und Auslesen der Werte braucht man etwas Geduld. Vermutlich aufgrund der Tatsache, dass die App mit dem App-Inventor "geschrieben" ist und alle Werte über eine serielle Verbindung gelesen werden. Die Anzeigeapp ist natürlich bedingt durch die BT-Schnittstelle etwas träger als die analoge CA-Anzeige, aber das dürfte in der Praxis keine Geige spielen und ist echt eher unter der Kategorie "Luxusproblem" zu sehen. :X3:

Bei einem älteren Android Smartphone (meiner üblichen "Navigationsschlampe") mit Android 5 oder 6 kam die Kopplung nicht zustande, aber das kann auch ein gerätespezifisches Problem gewesen sein.
 

marci

Dabei seit
12.03.2011
Beiträge
2.493
Ort
82362 Weilheim i.Obb.
Details E-Antrieb
GMAC / Puma und Fatbike Bafang Heckantrieb
Hmm, Android 5 oder 6? Könnte an der BT Version liegen, BT 2.0 und 3.0 wahren noch nicht so stabil bei 2 gleichzeitigen BT Verbindungen, vor allem wenn Du auf der einen Seite BT COM / UART und auf der anderen Seite A2DP Audio überträgst. Das hat sich erst deutlich verbessert mit Bluetooth V4+. Es kann allerdings auch an dem HC-05 liegen. die Trägheit von der Du schilderst, erinnert mich an ein UART Puffer Problem zwischen BT und UART/Seriell. Aber genau weiß ich das auch nicht mehr, die Modem-Zeiten und die Zeiten wo ich noch M2M hardware entwickelt habe sind lange her. Wenn ich Zeit hätte, würde ich mal ein anderes BT Modul verbauen, das auch BT4+ kann.. (siehe hier Bluetooth – König Blauzahn verbindet ). Ich habe einige Verbindungen mit dem MPe mal auf einem Samsung S8, S9, S10, S20 mit jeweils aktuellem Patchstand getestet, (allerdings ohne Audio parallel zu testen), da hat es meistens gut mit den Verbindungen geklappt, allerdings ist mir die Verzögerung bei der Anzeige von parametern und auch das Umschalten der S5 Stufen aufgefallen, (z.B. an den 2 angeschlossenen Temp Sensoren) aber das kann auch andere Ursachen gehabt haben.. Ich bin mir sicher, das man das mit wenig Aufwand noch besser hinkriegt :)
Jetzt werd ich ja schon wieder heiß auf den MPe, aber die Vernunft sagt, kümmere Dich lieber um Deien Familie ;-)
 

HolgiB

Dabei seit
05.01.2020
Beiträge
416
@marci: Die Probleme mit der Kopplung parallel zum Musikhören waren auf einem modernen Smartphone. Einem Xiaomi Redmi Note 8 Mini um genau zu sein, aber meine alte Möhre (Infos M808) kann durchaus einen uralt BT Stack gehabt habe. Bezüglich Verzögerung so ist das glaube ich eher der "Programmierung" der App geschuldet, da es ja mit dem MIT App Inventor gemacht wurde und das ist eher grafisches Zusammenklicken von Elementen, denn wirklich "programmieren". Dadurch hat man garantiert höhere Laufzeiten und damit auch Latenzen im Vergleich zu einer nativen Android App. Ich habe aber Verständnis dafür, dass man quasi als Ein Mann-Ingenieur zur MPe Entwicklung & Fertigung nicht auch noch Android Entwickler sein kann :)

Ansonsten solltest du eher deiner Vernunft folgen ! (y)

Der MPe läuft nicht weg und es ergibt sich auch in ein paar Monaten die Möglichkeit sowas zu testen.
 

marci

Dabei seit
12.03.2011
Beiträge
2.493
Ort
82362 Weilheim i.Obb.
Details E-Antrieb
GMAC / Puma und Fatbike Bafang Heckantrieb
@HolgiB ... Ansonsten solltest du eher deiner Vernunft folgen !...

Ups, hab mir gedacht, bis wie einen adäquaten Nachfolger gefunden haben, kann ich ja noch etwas experimentieren, aktuell geht es ein bisschen...
 

Anhänge

  • 20201213_134445.jpg
    20201213_134445.jpg
    170,3 KB · Aufrufe: 14
Thema:

Tester unseres MPe Computer / Controller

Tester unseres MPe Computer / Controller - Ähnliche Themen

sonstige(s) Performance: Motor nicht in jedem Fall ein Highlight: Prolog: Im Frühjahr 2013 kaufte ich das Bergamont E-Line C-N360 (NuVinci, Kettenantrieb) mit der Hardware-Version 0.4.0.3 und der Software-Version...
Test E-BIKE VISION 18Ah Akku für 26V PANASONIC Pedelecs 454Wh für Kalkhoff, Flyer &Co: > Die Frage nach der Reichweite von Elektrofahrrädern beschäftigt viele Neueinsteiger, welche ahnen, dass idealtypische Herstellerangaben in der...
Test E-BIKE VISION 25Ah Akku für 26V PANASONIC Pedelecs 625Wh für Kalkhoff, Flyer &Co: > Das 26V PANASONIC Antriebssystem ist mit bisher 1,2 Millionen Einheiten (Quelle: Derby Cycle 2011) eines der weltweit Meistverkauften. >...
Oben