Smart BMS 5-13S programmierbar - meine ersten Erfahrungen

Diskutiere Smart BMS 5-13S programmierbar - meine ersten Erfahrungen im Akkus, Batteriemanagement (BMS), Ladegeräte Forum im Bereich Diskussionen; Wenn ich die Inschrift unter dem Klarlack richtig interpretiere handelt es sich um einen BQ76940 von TI (http://www.ti.com/lit/ds/symlink/bq76940.pdf)
J

jajajim

so, ein weiteres Smart BMS ist aufgetaucht. Schon der Optik nach des Professors auf dem Teil und den Features ist das wohl kein OZ890. Könnte was von Texas sein, den China Pages nach.

http://www.greenbikekit.com/bms-pcm/smart-programmable-lithium-bms.html

http://www.jiabaida.com/products/zhinenbaohuban/2016/0422/44.html


bin geneigt das Ding zu bestellen, schon deswegen weil es bis 15s kann

des PCB noch:

Wenn ich die Inschrift unter dem Klarlack richtig interpretiere handelt es sich um einen BQ76940 von TI (http://www.ti.com/lit/ds/symlink/bq76940.pdf)
 
J

jajajim

Das BMS scheint grundsätzlich zu funktionieren. Als Versuchsaufbau dient ein 10s aus alten aufblähten mini Lipo's (460mah). Über Nacht wurden immerhin rund 0.1Volt von anfänglich 0.15 Volt "weg balanciert", wobei der Ladestand des Akkus von rund 65% auf 20% viel (wohl durch die viel zu kleine Kapazität des Akkus und der viel zu großen Differenz der dem einzelnen Zellen). Mittels PC Programmierung lassen sich sehr viele Einstellung vornehmen, wobei ich mich teilweise noch einlesen sollte (Programm ist größtenteils auf Englisch, teilweise aber auch " Chinesisch", von der Android Bluetooth-App scheint es keine Englische Version zu geben)

Ich hab die 36v, 30a-Version gekauft. Wahrscheinlich ließ sich auch auf die 15s-Version umprogrammieren (+ ein paar Lötbrücken müssen entfernt werden). Werd ich bei Gelegenheit noch testen.
 
Zuletzt bearbeitet von einem Moderator:
T

troebi

Mitglied seit
31.05.2017
Beiträge
13
Hallo zusammen,

bei meinem BMS (11s) funktioniert das Balancen der 11. Zelle nicht. Wenn ich mir das Datenblatt vom TI Chip ansehe, fehlt mir die Info, wie das die Zellen gebalanced werden - sprich, wie die Transistoren (die Balancewiderstände schalten).
Bin da auf der Fehlersuche. Laut Software wird Zelle 11 gebalanced, in Wirklichkeit nicht.

Über einen Tip bin ich sehr dankbar! ;)

Grüße
Tröbi
 
abachtern

abachtern

Mitglied seit
29.07.2012
Beiträge
339
Ort
Alpenrand
Details E-Antrieb
elfkw CST + Cute100H; Forumscontroller; 40,7V 5Ah
Hallo,
ich habe mal eine Frage ob an meinem Smart BMS noch was zu retten ist oder nicht.
Das BMS war angeschlossen und hat wunderbar funktioniert.
Dann wollte ich noch einen Schrumpfschlauch drüber machen und hab den das Balancerkabel und den Minus an der Batterie nochmals entfernt, damit ich den Schlauch einfädeln kann.
Leider hab ich bei noch nicht angelötetem B- den Balancerstecker angesteckt.
Dadurch ist wohl etwas kaputt gegangen. Kann ich das BMS in die Ablage rund packen oder besteht die Möglichkeit ein Bauteil zu tauschen.
Besten Dank an die Experten

Grüße

abachtern
 
M

manni_s

Mitglied seit
08.01.2018
Beiträge
15
Hallo
ich hatte auch ein Smart BMS von Greenbikekit, hier hat schon beim abstecken gereicht, das ich den Stecker etwas schief abgezogen habe,
natürlich in die falsche Richtung, Resultat TI IC Schrott, Vorwiderstände zum IC durchgebrannt.
Ich habe alles ersetzt, aber so richtigt Vertrauen habe ich nicht mehr in das Ding, da die Messwerte immer am hüpfen
waren und auch nicht mehr richtig Kalibrieren ließ.
Fazit: meine Reparatur war für die Tonne, was hilft ein BMS wenn es nicht richtig funktioniert.

Gruß
Manfred
 
Akkufritze

Akkufritze

gewerblich
Mitglied seit
24.07.2014
Beiträge
1.081
Ort
Bernburg
Also ich habe schon einige smart BMS verbaut und bisher hat da noch keines herumgezickt.
Habe auch noch einige da, falls benötigt.
Gruß Akkufritze
 
abachtern

abachtern

Mitglied seit
29.07.2012
Beiträge
339
Ort
Alpenrand
Details E-Antrieb
elfkw CST + Cute100H; Forumscontroller; 40,7V 5Ah
OK,
dann kommt es in die Tonne.
 
Drehfeld

Drehfeld

gewerblich
Mitglied seit
03.07.2014
Beiträge
362
Ort
Villach
Details E-Antrieb
Vom 2kg Hilfsmotor bis zum 10kW eBike
Wer möchte ich habe noch etliche dieser BMS bei mir rumliegen. Programmieradapter hätte ich zwei.
Also wer möchte dem kann ich für kleines Geld (geht in die Trinkgeldkasse der Firma) gern so ein BMS schicken. Ich kann den BMS leider nicht 100% vertrauen, da immer mal wieder ein Akku in die Unterspannung gekommen ist. (Habe mehrere Hundert mit diesem BMS als 6S Akkus aufgebaut)
Die BMS sind alle min. 2 Jahre alt und teilweise nicht mehr in den ESD Schutzverpackungen.
Den Programmieradapter würde ich nur leihweise rausgeben, da ich Ihn selbst immer wieder brauche (nur für Einzelprojekte).
 
Drehfeld

Drehfeld

gewerblich
Mitglied seit
03.07.2014
Beiträge
362
Ort
Villach
Details E-Antrieb
Vom 2kg Hilfsmotor bis zum 10kW eBike
Es gibt programmierbare BMS auch für 16S. Ob diese den OZ Chip verwenden glaube ich nicht. Der Chip ist für 13 Zellen ausgelegt. Man kann für höhere Zellenzahl aber die BMS "seriell" verschalten.
Ich würde dir aber empfehlen ein fertiges "dummes" 16S BMS für LiFe fix fertig zu kaufen. Über die "üblichen" Zulieferer aus Asien bekommst um 50€ LEIDER genau das Selbe was du hier beim "Fachgeschäft" für 150€ bekommst.
 
L

labella-baron

Mitglied seit
19.07.2008
Beiträge
10.939
Details E-Antrieb
Crystalyte 209, LiFePo 36V 4,6Ah von A123
Ich würde dir aber empfehlen ein fertiges "dummes" 16S BMS für LiFe fix fertig zu kaufen. Über die "üblichen" Zulieferer aus Asien bekommst um 50€ LEIDER genau das Selbe was du hier beim "Fachgeschäft" für 150€ bekommst.
Kennst du zufällig auch ein Capacity-BMS für unter 50€ - die gleichen bei LiFePO viel schneller aus.
 
Drehfeld

Drehfeld

gewerblich
Mitglied seit
03.07.2014
Beiträge
362
Ort
Villach
Details E-Antrieb
Vom 2kg Hilfsmotor bis zum 10kW eBike
Hi, nein leider bin ich selbst bei der Suche nach kostengünstigen, fertigen "aktiven" BMS gescheitert. Die BMS die mit Potentialunterschiede über eine gemeinsame Kapazität ausgleichen haben sich in Serie nie durchgesetzt. Nach meinen eigenen "Arbeiten" in diesem Bereich habe ich als Grund dafür die relativ hohen Verlustleistungen bei großen Kapazitäten als Grund angenommen. Mit add-e haben wir 2 eigene BMS designed und uns jeweils für die "Bleeding" Variante entschieden.
Das einzige was ich bisher mal in den Händen aber nur für eine 3S Applikation hatte ist von einer sehr guten Slowenischen Firma. Aber kann zu dem BMS nicht wirklich was sagen da es preislich für mich nicht relevant war um sich länger damit auseinander zu setzten. Aber vielleicht ist es ja was für dich.
Weil es hier aber eigentlich um das SmartBMS von BMS Battery geht hier noch ein Bild der Variante die ich lange zeit verbaut habe und auch jetzt noch für kleiner Projekte verwende. Es gibt das BMS auch mit LED in den "Bleeding" Kreis so das man auch optisch erkennt wenn eine Zelle "gebalanced" wird.
Mit geringem Aufwand kann das BMS so verschaltet werden, dass der Lade und Entladegerät in einem ausgeführt wird.
Die Strommessung direkt über die FET ist allerdings sehr ungenau und sollte nicht für Messungen verwendet werden.
Auch wenn ich nicht möchte das es hier zu einem Verkaufsthread wird gebe ich dennoch mal einen Richtwert für dieses BMS aus Österreich an. Abhängig von der Stückzahl liegen wir so bei 20€ inkl. Versand. Genaueres bitte über PN hier soll es weiterhin um die Funktionalität des BMS gehen.
upload_2018-3-6_9-14-36.png
 
L

labella-baron

Mitglied seit
19.07.2008
Beiträge
10.939
Details E-Antrieb
Crystalyte 209, LiFePo 36V 4,6Ah von A123
Aber kann zu dem BMS nicht wirklich was sagen da es preislich für mich nicht relevant war um sich länger damit auseinander zu setzten. Aber vielleicht ist es ja was für dich.
Ist offenbar für Photovoltaik-Anlagen gedacht und vier Stück davon für 16s sind zum spazieren fahren sicher zu schwer ;)

Danke dir.
 
old-papa

old-papa

Mitglied seit
08.05.2011
Beiträge
148
Details E-Antrieb
Jetzt in der Nutzphase, aber Anfänger...
Hallo (ich wärm die Leiche noch mal auf... ;) ),

ich habe seit Jahren ein paar dieser BMS liegen und nie verbaut. Meine Headway-Zellen (12s 38120, 10Ah) habe ich die ganzen Jahre über ein Graupner Ultramat 18 mit intergriertem (300mA) Balancer geladen, soweit hatt das all die Jahre geklappt. Fast genauso lange habe ich noch einen 2. Satz Zellen liegen, daraus habe ich jetzt einen Wechselakku gestrickt. Natürlich wollte ich endlich mal die BMS verwursten, also dann. Bestellt hatte ich die hier als 12x LiFEPo4 Version über eine Sammelbestellung.
Nachdem ich mir jetzt nochmal diesen Monsterthread durchgelesen habe, habe ich das Teil angestöpselt (erst Power-, dann Balancerkabel) und das Ultramat auf 12 Zellen LIFEPo4 mit zunächst 1A Ladestrom ohne internen Balancer programmiert. Und seit dem habe ich Probleme...
Nach ein paar Minuten meldet das Ding eine "Unterbrechnung" und das wars.
Nachgemessen, 11 Zellen etwa 3,3 bis 3,4V, eine nur 2,4V. So hatte ich das auch ohne BMS schon gemessen, die eine Zelle hätte ich vorher auffrischen sollen. Aber dann: nur 0,2A Ladestrom, dass sollte doch gehen. Leider geht das auch nicht, es dauert zwar etwas länger, doch die "Unterbrechnung" kommt nach ca. 3-4Minuten wieder.
Ok du Knalltüte, jetzt gehts ans Labornetzteil...
Eingestellt auf 50V/1A (Leerlauf) und los. Er lädt kurz, die Gesamtspannung steigt unter "Last" auf etwa 40V und das BMS schaltet ab.
So schnell gebe ich nicht auf, also zunächst einen Programmieradapter besorgt (hier aus dem Forum) und das verbaute BMS untersucht. Vom Chinamann waren 12 Zellen mit 3,7V Over- und 2V Undervolt einprogrammiert. Zwar nicht ganz das was LiFEPo4 will, aber zumindest im Rahmen. Die 10/40A Lade/Entladestrom passen auch, sollte also funktionieren.
Einzig der Temperatursensor ist völlig daneben, der zeigt immer so 75°C an. Unter Optionen habe ich gesehen, dass ein Sensor mit 51kOhm eingetragen war, verbaut ist einer mit 10k. Allerdings habe ich derzeit keine Möglichkeit die Temperaturkennlinie (die man auch programmieren kann/muss) zu vermessen, ich muss mal ein in etwa passendes Datenblatt zu solchen Möppeln suchen. Per Trail & Error habe ich die Werte erstmal so hingefummelt, dass jetzt etwa 24°C angezeigt werden, daran kann es also auch nicht liegen.
Die Zellen haben noch immer etwa 3,3-3,4V bzw. die eine ist auf knapp 2,9V gestiegen. Diese werde ich jetzt händisch aufziegeln, besser ist das. Im Ladebetrieb kann ich die Zellen derzeit nicht alle zugleich messen, ich müsste ein Notebook an den Programmieranschluss stöpseln.
Dennoch: Ich kann das Akkupack über das BMS einfach nicht laden. Verbaut habe ich dieses hauptsächlich um im Fahrbetrieb keine Zelle tief zu entladen, zwei sind mir dabei schon gestorben :(

Allerdings habe ich noch arge Probleme, das Tool in Englisch zu verhirnen. Mit einigen Einstellungen komme ich klar, mit anderen nicht. Dabei geht es mir nur um die Basics, ins Eingemachte will ich eh nicht.

Old-Papa
 
Drehfeld

Drehfeld

gewerblich
Mitglied seit
03.07.2014
Beiträge
362
Ort
Villach
Details E-Antrieb
Vom 2kg Hilfsmotor bis zum 10kW eBike
@old-papa: Wie kann man dir da nun helfen? Du hast den Programmieradapter und scheinst grundsätzlich auch zu wissen was du tuest.
Daher bin ich ganz bei dir. Die eine Zelle direkt laden (langsam und nur unter Aufsicht und Temperaturüberwachung), danach die Einstellung am BMS richtig einstellen und dann berichten. Oder hättest du noch eine Verständnisfrage zum BMS?
 
old-papa

old-papa

Mitglied seit
08.05.2011
Beiträge
148
Details E-Antrieb
Jetzt in der Nutzphase, aber Anfänger...
Hauptsächlich habe ich Verständnisprobleme mit der Software. Außer den basics verstehe ich nix ;)

Die eine Zelle ist gerade am laden, mal sehen, was dann ist. Mich irritiert allerdings, dass das BMS einfach nach ein paar Minuten abschaltet, obwohl nicht eine Zelle wirklich voll ist. Ich könnte den Balancerstecker jedes mal abziehen und über einen Adapter direkt ans Ultramat hängen und mit diesem balancieren, doch das wäre mir zu doof. Dann wäre das BMS nur im Fahrbetrieb (Entlademodus) dran.

Old-Papa
 
L

labella-baron

Mitglied seit
19.07.2008
Beiträge
10.939
Details E-Antrieb
Crystalyte 209, LiFePo 36V 4,6Ah von A123
die eine ist auf knapp 2,9V gestiegen.
Kenne das BMS nicht.
Aber konntest du die Spannung jener Zelle beim Laden beobachten?
Könnte das BMS deren Innenwiderstand indirekt messen?
Wenn dieser erhöht ist oder sich innerhalb kurzer Zeit erhöht, dann wäre ja eine Abschaltung des Ladens durch das BMS folgerichtig.
 
old-papa

old-papa

Mitglied seit
08.05.2011
Beiträge
148
Details E-Antrieb
Jetzt in der Nutzphase, aber Anfänger...
So eine Funktion hat das BMS nicht. Der Innenwiderstand dieser Zellen (noch mit dem Ultramat 18 gemessen) liegt zwischen ca. 3 und 10mOhm.

Old-Papa
 
L

labella-baron

Mitglied seit
19.07.2008
Beiträge
10.939
Details E-Antrieb
Crystalyte 209, LiFePo 36V 4,6Ah von A123
So eine Funktion hat das BMS nicht. Der Innenwiderstand dieser Zellen
Geladen wird doch zunächst mit Konstantstrom. Wenn sich der Lade-Innenwiderstand nach kurzer Zeit stark erhöhen würde, dann würde ja bei einer Spannungserhöhung von mehreren 100mV auch abgeschaltet werden.

Anderes Szenario: Die Zelle hat einen Schlag oder kann keine weitere Ladung mehr aufnehmen. Dann geht bei LiFePO die Spannung auch blitzartig durch die Decke.
 
old-papa

old-papa

Mitglied seit
08.05.2011
Beiträge
148
Details E-Antrieb
Jetzt in der Nutzphase, aber Anfänger...
Kann alles sein, doch misst oder berechnet der OZ890er Chip den Innenwiderstand? Ich vermute mal nicht.
Hier ein paar Fotos zur Config und zu einem Scan.
Ich hatte noch versehendlich Zelle 9 für kurze Zeit nachgeladen, daher ist die bei 3,49V. Die schlappe Zelle war Zelle 10, die steht jetzt bei 3,27V

Ist die Config so iO?
Eine kurze Erklärung zu den einzelnen Zeilennummern wäre hilfreich ;) Ein paar sind klar, doch ansonsten... :(

Config1.jpg


Config2.jpg


Config3.jpg


Config4.jpg


Scan1.jpg


Bisher habe ich noch nicht direkt beim Laden loggen können, ich muss zunächst mein kleines Notebook installieren. das Labornetzteilmonster (Rigol) möchte ich nicht hier ins Arbeitszimmer schleppen ;) Und das Graupner schaltet ja immer gleich ab.

Old-Papa
 
Thema:

Smart BMS 5-13S programmierbar - meine ersten Erfahrungen

Oben