Smart BMS 5-13S programmierbar - meine ersten Erfahrungen

Diskutiere Smart BMS 5-13S programmierbar - meine ersten Erfahrungen im Akkus, Batteriemanagement (BMS) und Ladegeräte Forum im Bereich Diskussionen; AW: Smart BMS 5-13S programmierbar - meine ersten Erfahrungen na da kennt sich jemand aber wirklich aus :) danke! ist immer schoen kompetente...
I

izeman

Dabei seit
18.06.2011
Beiträge
175
Punkte Reaktionen
3
AW: Smart BMS 5-13S programmierbar - meine ersten Erfahrungen

na da kennt sich jemand aber wirklich aus :) danke! ist immer schoen kompetente antworten 'ohne raten und halbwissen' zu bekommen.

also auf ladestand kann ich verzichten. das sagt mir eh mein wattmeter was ich verbraucht habe.

eine moeglichkeit den allgemeinen betriebszustand anzuzeigen gibt's vielleicht? so in der art: strom liegt an und das ding laeuft? so dass man auf einen blick erkennen kann ob man vergessen hat abzustecken? obwohl soweit ich das verstanden habe ist es ja so gedacht dass das bms staendig mit dem akku verbunden ist, oder? dann wuerde die led (zwar sehr langsam aber doch) den akku leersaugen.
 
H

haegar

Dabei seit
12.10.2008
Beiträge
2.186
Punkte Reaktionen
12
Ort
34379
Details E-Antrieb
Bafang 36V mit A123 +LiMn
AW: Smart BMS 5-13S programmierbar - meine ersten Erfahrungen

Nimmst du eine Ultrahelle Led mit Vorwiderstand die auf etwa 10µA begrenzt am Ausgang ist das kontrolle genug, die dinger leuchten dann immer noch gut erkennbar.
40V =4.000.000Ohm *0,000.01A. Nach 1 Millionen Stunden wäre der 10Ah Akku dann alle :)
Der Versand ab 50 gramm ist 1.45, oder ich schick dir nur das platinenteil mit den Leds für umsonst, schick ne PN mit Adresse.
 
I

izeman

Dabei seit
18.06.2011
Beiträge
175
Punkte Reaktionen
3
AW: Smart BMS 5-13S programmierbar - meine ersten Erfahrungen

Nimmst du eine Ultrahelle Led mit Vorwiderstand die auf etwa 10µA begrenzt am Ausgang ist das kontrolle genug, die dinger leuchten dann immer noch gut erkennbar.
40V =4.000.000Ohm *0,000.01A. Nach 1 Millionen Stunden wäre der 10Ah Akku dann alle :)
Der Versand ab 50 gramm ist 1.45, oder ich schick dir nur das platinenteil mit den Leds für umsonst, schick ne PN mit Adresse.

-> PN
Danke!
 
torcman

torcman

Dabei seit
02.11.2010
Beiträge
6.816
Punkte Reaktionen
3.491
Ort
bei Stuttgart
Details E-Antrieb
102.096 km mit BionX 48V 40.7V 36V seit 2010
AW: Ein einziger Anschluss fuer Charge und Discharge


hier das Foto der ecitypower BMS Bestueckung der Bleeding Resistoren

mit Pfeil - Kurzschluesse zwischen den Zellen eines Akku moeglich:
mit Linie - tanzender Bauteile, Loetqualitaet?

aufs Bild mit rechter Maustaste und Grafik anzeigen - dann sieht man mehr Details

ecitypower_bleeding_resistors.jpg




Kanal 1, wo der MOSFET 22mA permanent von der Zelle 1 des Akku zieht und somit mir die Zelle auf 0.2V entladen hat.

Siehe links oben der weise Widerstend und der oberste MOSFET

ecitypowerBMS-Ch0-22mA-leakage.jpg


Uber die Qualitaet der Bestueckung kann trefflich streiten, solange kein Akku, wie bei mir, kaputt gemacht wird.

Fuer mich ist die Qualitaet nicht akzeptabel, viele Bauteile verlassen ihre Position (Loetpadsgrenzen) und ruecken zu nahe an Nachbarn, sodass der minimaler Abstand nich angehalten wird, wegen Feuchte und Dreck zum Kurzschluss fuehrt.

So ein Board wuerde eine Produktion mit optischer automatischen Kontrolle des Versatzes der Bauteile niemals verlassen duerfen.

--------

Das waren Bilder nach der Reinigung, vorher hat es folgends ausgesehen:


ecitypower vor dem Reinigen.jpg
 
Zuletzt bearbeitet:
G

gervais

Dabei seit
20.03.2010
Beiträge
3.816
Punkte Reaktionen
47
AW: Ein einziger Anschluss fuer Charge und Discharge

So ein Board wuerde eine Produktion mit optischer automatischen Kontrolle des Versatzes der Bauteile niemals verlassen duerfen.

Aber das hast Du doch bei dem Preis nicht ernsthaft erwartet. Das Board geht nach der Bestückung in den Karton, fertig. Bei der Retourenquote sind defekte Chargen mit einkalkuliert. Kein Fertigungs-, sondern ein EK- Thema. Selbst wenn Du es zurückschickst (bzw. reklamierst), wird wieder nur in den Karton gegriffen und Du bekommst die gerade aktuelle Version....Lotto.
 
D

Dieter

Dabei seit
11.12.2009
Beiträge
994
Punkte Reaktionen
430
Ort
Raum Böblingen
Details E-Antrieb
Mittelmotor System - Eigenkonstruktion
AW: Ein einziger Anschluss fuer Charge und Discharge

Anbei Bilder der beiden Exemplare, die ich von einem Forumsmitglied bezogen habe - für mich, selbst bei Betrachtung mit dem Mikroskop, einwandfrei und so wie ich es erwarte.

Weitere 3 Exemplare, die ich letzte Woche erhalten habe, sehen genau so aus.

Lediglich die manuell ausgeführten Lötungen der Leistungs-Mosfets lassen zu Wünschen übrig. Da sieht man deutlich, dass es schnell gehen musste.
Solange die Funktion ok ist, habe ich damit aber kein Problem.

Wie ich sehe hast Du die Version, bei der die LEDs bestückt sind - kommen bestimmt aus einer anderen Charge.

Dieter
 

Anhänge

  • IMG_0157.jpg
    IMG_0157.jpg
    159,4 KB · Aufrufe: 575
Alfred

Alfred

Themenstarter
Dabei seit
09.02.2010
Beiträge
393
Punkte Reaktionen
141
Ort
Österreich
Details E-Antrieb
26", 28" elfKW 250W HR, (10S1P,2P INR21700-50G )
AW: Ein einziger Anschluss fuer Charge und Discharge

Hallo Dieter,

Torcman hat die ältere Version siehe hier oder hier
Die neueren, wie sie von BMS Battery vertrieben werden, sind einwandfrei bestückt!
Die ersten Charchen von BMS Battery wurden auch mit LED's ausgeliefert, diese wurden aber später eingespart...

Gruß
Alfred
 
torcman

torcman

Dabei seit
02.11.2010
Beiträge
6.816
Punkte Reaktionen
3.491
Ort
bei Stuttgart
Details E-Antrieb
102.096 km mit BionX 48V 40.7V 36V seit 2010
AW: Ein einziger Anschluss fuer Charge und Discharge

@ gervais

Aber das hast Du doch bei dem Preis nicht ernsthaft erwartet. Das Board geht nach der Bestückung in den Karton, fertig

doch,

das erwarte ich auch bei einem Geraet fuer 1.99 Euro.

Eine automatische optische Kontrolle kostet gar nichts, eine einfache digital kamera (200$) + ein bisschen Software, dass das Bild des DUT (deivice under test) mit einem Bild eines Golden Device (muster) auf Bauteile Existenz, Versatz, falsche Bestueckung etc analysiert. Dauerts nicht mal ein Paar Sekunden.

Ich rede von optischer Kontrolle nicht von elektrischen Messungen, die sind immer teurer, weil man ein Nagelbett (2k$) plus manipulator plus Messintrumente (5-10k$) plus speziell geschriebene Final Test Software (5-10k$) braucht.


@ Dieter

deine sehen gut aus. Sind auch die neueren, woher hast Du die?

@ Alfred

http://www.ecitypower.com/index.php?option=com_content&view=article&id=15&Itemid=82

ja der ist es.

Reparatur:

- alle Bauteile um den MOSFET und derselber raus, Stellen gereignigt (Isopropan, Buerste + Pressluft)

- die Rs sind OK, der MOSFET ist kaputt, Drain-Source-Widerstand (Gate mit Source verbunden) 58 Ohm

- alle Pads gereignigt

- Rs wieder rein

- MOSFET vom Kanal 13 raus und in Kanal 1 rein

- zusaetzlich alle Rs die schief waren, wie in den Bildern oben, gerade geloetet

- 37V angeschlossen, Strom 50uA (springt immer wieder auf 650uA - das BMS geht immer wieder an und schaut ob Balancer angschlossen)

- Alle Balancer-Eingaenge sequentiel (zwei zu ein, drei zu zwei, etc) Widerstand groesser 40 MOhm, also kein Kriechstrom

heute abend geht der Akku ran

ich kriege es schon hin :mad:
 
D

Dieter

Dabei seit
11.12.2009
Beiträge
994
Punkte Reaktionen
430
Ort
Raum Böblingen
Details E-Antrieb
Mittelmotor System - Eigenkonstruktion
AW: Ein einziger Anschluss fuer Charge und Discharge

@ Dieter

deine sehen gut aus. Sind auch die neueren, woher hast Du die?
Hallo Peter,

die beiden abgebildeten Exemplare sind von Alfred - allerdings ohne die Anschlüsse zu einer ext. LED-Zeile.

Die erwähnten 3 weiteren Exemplare habe ich von BMSBattery bezogen - über HKPOST und DHL als zollamtlich abgefertigtes Einschreiben an die Haustür geliefert .

Gruß
Dieter
 
torcman

torcman

Dabei seit
02.11.2010
Beiträge
6.816
Punkte Reaktionen
3.491
Ort
bei Stuttgart
Details E-Antrieb
102.096 km mit BionX 48V 40.7V 36V seit 2010
AW: Ein einziger Anschluss fuer Charge und Discharge

Danke Dieter

dann hatte ich halt Pech gehabt. Die Quellen merke ich mir.

So, das reparierte BMS an den Akku angeschlossen, keine Stroeme fliessen in die Balance Kabel. Die LEDs leuchten, die Spannungen stimmen. Also fertig.
 
I

izeman

Dabei seit
18.06.2011
Beiträge
175
Punkte Reaktionen
3
AW: Ein einziger Anschluss fuer Charge und Discharge

brauch wieder mal eure hilfe :)

ich hab das erste der 3 bms angeschlossen und hab natuerlich mist gebaut. ich hab den 13s stecker verkehrt rum angeschlossen. also erste zelle = letze, oder plus gleich minus, und vice versa. es hat beim anstecken des balancer anschlusses an meinem selbstgebauten parallel adapter kurz geblitzt und der 7te pin ist verschmort.

dann hab ich den fehler erkannt ;) und hab alles richtig umgeloetet (bzw die pins am stecker korrigiert).

das bms selbst hat wohl nix abbekommen. soll heissen: eeprom lesen/schreiben funktioniert und er kann auch die zellenspannungen auslesen. allerdings liegen die tlw arg daneben. die erste zelle zeigt er als 200mv, die 2te als 4800mv und die restlichen werte sind tlw 200mv daneben und springen recht arg herum.

kann natuerlich auch daran liegen dass ich ein paar leds eingeloetet habe. kann das ein problem sein wenn die verkehrt rum drin sind? die sind sooo winzig, da kann ich einen fehler nicht ausschliessen.

gibt es eine moeglichkeit das bms zu pruefen und wieder in gang zu bringen? dass es sich finanziell nicht auszahlt ist mir klar, ich moechte aber nicht wieder 2mo auf die lieferung eines neuen warten.
 
Alfred

Alfred

Themenstarter
Dabei seit
09.02.2010
Beiträge
393
Punkte Reaktionen
141
Ort
Österreich
Details E-Antrieb
26", 28" elfKW 250W HR, (10S1P,2P INR21700-50G )
AW: Ein einziger Anschluss fuer Charge und Discharge

Hallo Iceman

kontrolliere nochmal ob alle Balanceranschlüsse mit den jeweiligen Zellen verbunden sind.
Was ist das für ein Akku 10S, 12S?
Hast du die nicht verwendeten Anschlüsse verbunden?
(siehe Bild - Beispiel eine 10S)
An den LED's sollte es nicht liegen, außer du hast dort einen Kurzschluss fabriziert ;)

Es gäbe auch die Möglichkeit die angezeigten Spannungen zu kalibrieren, dazu benötigst du aber ein genaues Multimeter.
Im Normalfall ist das aber nicht nötig, da diese Anzeigen vom Werk her schon sehr genau sind.

Wenn alle Stricke reißen, kannst du auch ein SmartBMS von mir haben, habe wieder ein paar auf Lager..
(sogar mit nachbestückten LED's :))

Gruß
Alfred
 

Anhänge

  • Lötbrücken für nicht verwendete Anschlüsse.jpg
    Lötbrücken für nicht verwendete Anschlüsse.jpg
    40,8 KB · Aufrufe: 368
Zuletzt bearbeitet:
I

izeman

Dabei seit
18.06.2011
Beiträge
175
Punkte Reaktionen
3
AW: Ein einziger Anschluss fuer Charge und Discharge

danke alfred.

es sind 2x 6s in serie. also 12s. ist auch so im board eingestellt und NICHT gebrueckt. hab ich auch gelesen. es ist aber nicht die 12te zelle die daneben liegt, sondern die erste. bei den funktionierenden boards wird 13s einfach als N/A angezeigt, und ALLE werte stimmen auf ein paar mV genau.

ich denke also ich hab was geschossen. ich werde alle leds wieder entfernen. vielleicht ziehen die ja einen kurzschluss. ansonsten denke ich werde ich auf dein angebot zurueck kommen. ->PN :)
 
H

haegar

Dabei seit
12.10.2008
Beiträge
2.186
Punkte Reaktionen
12
Ort
34379
Details E-Antrieb
Bafang 36V mit A123 +LiMn
AW: Ein einziger Anschluss fuer Charge und Discharge

kannst ja auf die Leds mal kurz 1,8V geben mit 2 spitzen kontakten geben, dann sollten die leuchten wenn sie ok sind.
shit happens :-(
 
I

izeman

Dabei seit
18.06.2011
Beiträge
175
Punkte Reaktionen
3
AW: Ein einziger Anschluss fuer Charge und Discharge

kannst ja auf die Leds mal kurz 1,8V geben mit 2 spitzen kontakten geben, dann sollten die leuchten wenn sie ok sind.
shit happens :-(

einfach so? ohne vorwiderstand? dachte an eine 1.5v batterie und so geschaetzen 300ohm. oder hab ich mich verrechnet?
 
H

haegar

Dabei seit
12.10.2008
Beiträge
2.186
Punkte Reaktionen
12
Ort
34379
Details E-Antrieb
Bafang 36V mit A123 +LiMn
AW: Ein einziger Anschluss fuer Charge und Discharge

bei 1,5V tut sich wohl noch nix, rote leds fangen bei etwa 1,6V an zu leuchten und haben ihre nennspannung etwas höher, 1,8-2V glaub ich.
Der Vorwiderstand auf dem BMS ist nötig damit sie nicht die Zellspannung abbekommen ( 3,7V) , pro volt zuviel 50Ohm bei 20mA Betriensstrom.
Kann sein daß die SMD leds aber viel weniger benötigen aber mit ner vollen Batterie hast du vl gerade genug Spannung, funktionieren tut das jedenfalls
 
I

izeman

Dabei seit
18.06.2011
Beiträge
175
Punkte Reaktionen
3
AW: Ein einziger Anschluss fuer Charge und Discharge

bei 1,5V tut sich wohl noch nix, rote leds fangen bei etwa 1,6V an zu leuchten und haben ihre nennspannung etwas höher, 1,8-2V glaub ich.
Der Vorwiderstand auf dem BMS ist nötig damit sie nicht die Zellspannung abbekommen ( 3,7V) , pro volt zuviel 50Ohm bei 20mA Betriensstrom.
Kann sein daß die SMD leds aber viel weniger benötigen aber mit ner vollen Batterie hast du vl gerade genug Spannung, funktionieren tut das jedenfalls

du hast prinzipiell recht. die smd leds kommen auch mit weniger zurecht. ich habs einfach mit einer 1.5v batterie probiert. zum TESTEN wars genug. man konnte erkennen ob die led leuchtet. fuer den echtbetrieb sind 1.5v definitiv zu wenig.

hab jetzt in das zweite bms alle leds eingeloetet und das tut einwandfrei. bleedet da jetzt total suess mit ein paar mA dahin. es zeigt einen strom von 38mA an. keine ahnung fuer was fuer akkus das ding gedacht ist, aber sicher nicht fuer 10a und mehr *ggg*

werde wohl den widerstandsmod machen. sonst passiert hier ja garnix.

btw: was heisst die einstellung "external / internal bleeding" ?
 
I

izeman

Dabei seit
18.06.2011
Beiträge
175
Punkte Reaktionen
3
AW: Ein einziger Anschluss fuer Charge und Discharge

jetzt moechte ich mal schnell ein paar erfahrungen los werden :)

zum laden verwende ich eine 600w power supply/charger von bms. eingestellt sind 10a max ladung, abschaltung bei 50v.

ich habe also alles angeschlossen, und habe mit dem laden begonnen. der lader laedt fuer 2s, dann hoert er wieder auf. nach ein paar sekunden laedt er wieder, dann hoert er wieder auf. im scan modus zeigt das bms bei pos17 (current) 15.000ma ladung. das dazwischen gehaengte wattmeter zeit 10.00a. soweit mal zu anzeigegenauigkeit des bms. also bin nicht dumm, und setze den OC wert auf 15a. das ist zu wenig. also mal forsch auf 40a. jetzt laedt das ding wunderbar, und bei 4v fangen die ersten zellen an zu bleeden. das passiert schon nach 2min, da die 2 6s 5000mah seriell auf storage (3.85v) geladen waren.

ploetzlich faengt es an zu rauchen. das ist ja im allgemeinen kein gutes zeichen. ;) ich steck sofort alles ab. entwarnung: ich hatte den akku (da ich ja erstmal nur das bms und interface getestet habe) mit super duennen draehtchen angehaengt. klar dass die die 10a ladung nicht lange mitmachen. also begann das minus kabel einfach durchzuschmoren. gefahr erkannt, gefahr gebannt. jetzt kommt erstmal ein vernuenftiges batteriekabel dran. dann sehen wir weiter.

kann mir jemand erklaeren warum das bms meint dass die ladung 15a betraegt, obwohl es nur 10a sind? trotz calibrierung, und einem korrekturfaktor von 0.65 zeigt es immer noch die falschen werte an.
 
T

trucki

AW: Ein einziger Anschluss fuer Charge und Discharge

Hallo,

ich habe kein SmartBMS, überlege aber eines für einen selbstgebauten LIPO Akku zu kaufen.
Da ich mir gerne das Geld für den I2C Adapter sparen würde habe ich ein bisschen gegoogled:

http://endless-sphere.com/forums/viewtopic.php?f=14&t=20971&start=30

Gibt es eine ältere Version des OZ890 Debug Tools zum Download (O2.zip) in der man als Adapter den guten alten Phillips Parallel Port I2C Adapter einstellen kann.
Eventuell reicht es diesen Adapter zu löten und die alte Version zu verwenden.

Ich habe mal die Version von BMSBattery(0.87) und die Cowboy Version (O2.zip - 0.75) installiert. Wie man auf den Screenshots sieht kann man einmal den Paralleladapter auswählen und einmal nicht.

Gruß,
Trucki

Cowboy.pngOZ890.png
 
Alfred

Alfred

Themenstarter
Dabei seit
09.02.2010
Beiträge
393
Punkte Reaktionen
141
Ort
Österreich
Details E-Antrieb
26", 28" elfKW 250W HR, (10S1P,2P INR21700-50G )
AW: Ein einziger Anschluss fuer Charge und Discharge

btw: was heisst die einstellung "external / internal bleeding" ?

Externes Bleeding ist das, was das SmartBMS macht, Balancing mit externen Bleedingwiderständen.
Der OZ980 kann auch internes Bleeding...
Bei Bedarf kann ich dir das 80-seitige Datenblatt des OZ890 zukommen lassen, da kannst du dann schmökern ohne Ende ;)

kann mir jemand erklaeren warum das bms meint dass die ladung 15a betraegt, obwohl es nur 10a sind? trotz calibrierung, und einem korrekturfaktor von 0.65 zeigt es immer noch die falschen werte an.

Das Kalibrieren betrifft nur die Stromanzeige bei Idle - Mode!
Du musst an der Einstellung "Rsense (mohm)" drehen und dich so an die korrekte Anzeige heran tasten.
Versuchs mal mit 2.900 mr

Eventuell reicht es diesen Adapter zu löten und die alte Version zu verwenden.

Danke für den Hinweis!
Würde mich auch interessieren ob's geht :)

Gruß
Alfred
 
Thema:

Smart BMS 5-13S programmierbar - meine ersten Erfahrungen

Smart BMS 5-13S programmierbar - meine ersten Erfahrungen - Ähnliche Themen

Empfehlung 10s Smart BMS mit 20-30A: Hallo zusammen, ich suche für mein eBike ein 10s Smart BMS mit 20 oder 30A. Wichtig wäre... - Handy (Apple IOS) App (bluetooth Verbindung) wo...
Standard BMS für Bionx 48V Akku: Hallo, ich habe von einem Kumpel das Fahrrad zum Nachschauen. Der Akku funktionierte nicht und ich dachte mir, dass so eine Akku zu reparieren...
Kapazitätsmessung an neuem China Akku und Erfahrung mit Samsung 29E: Ich hatte die Tage mal einen China Akku von einem Bekannten da. Den hatte er für 355€ bei Ebay gekauft. Er meinte er ist defekt. Im Endeffekt...
S: Info zur Funktionsweise des BMS smart connect 5.1: Hallo, liebe Foristen Wo finde ich oder wer kann und mag mir etwas zur Funktion/-sweise des in meinem alten Diamant-/BionX-Rad verbauten BMS...
erledigt Samsung NCM/SDI 12s1p (44v) und 13s1p (48v) 60Ah akkus (zellen wie BMW i3)~2800Wh: Verkaufe Samsung SDI LiIon 13s1p/12s1p. Genial fur autos, cargo ebikes, boote, elektroscooter usw Innwiederstand eine zelle 0.5mOhm AC, DC...
Oben