Programmierung BBS01 / BBS02

Diskutiere Programmierung BBS01 / BBS02 im Controller/Regler, Fahrerinformation & Elektronik Forum im Bereich Diskussionen; Was meinst du mit "du bist unpräzise"? Ich spüre es zum einen in den Pedalen und zum anderen sehe ich es im Display, wann der Motor wieder...
C

calmato60

Dabei seit
18.06.2022
Beiträge
10
Punkte Reaktionen
1
Es wird nicht nur am Tretstop liegen. Wenn sich sonst nichts geändert hat, dann wird der Motor zügig wieder einschalten, wenn du wieder zu treten beginnst. Du bist unpräzise.
Was meinst du mit "du bist unpräzise"?

Ich spüre es zum einen in den Pedalen und zum anderen sehe ich es im Display, wann der Motor wieder einsetzt. Besonders gut spürbar, wenn es leicht bergauf geht. Der Motor schaltet mit PAS=4 NICHT zügig wieder ein.
Ich habe mitgezählt wieviele Kurbelumdrehungen der Motor nach dem Tretstopp braucht um wieder einzusteigen. Es sind genau 2,5 - 3 komplette Umdrehungen.

Es ist jederzeit reproduzierbar.
 
K

kfs

Dabei seit
02.04.2016
Beiträge
925
Punkte Reaktionen
333
Die Parameter haben Bezeichnungen, die man im der Parameterdatei finden kann. Einen Parameter der Bezeichnung PAS gibt es nicht.

PAS Signale bis Start = Start Degree Number = SDN = 4 bei dir.

Ich habe eine Vermutung, warum der Motor bei dir nicht zügig wieder einschaltet. Es liegt nicht bzw. nur ganz wenig an SDN=4!

Wenn es leicht bergauf geht und du legst einen Tretstopp ein, dann ändert doch vielleicht die Geschwindigkeit. Wenn es nicht am Tretstop liegt und es liebt nicht am Tretstop an sich, was ändert sich dann noch bei einem Tretstop? Warum machst du überhaupt einen Tretstop, wenn es bergauf geht. Das meine ich mit «unpräzise».
 
C

calmato60

Dabei seit
18.06.2022
Beiträge
10
Punkte Reaktionen
1
Die Parameter haben Bezeichnungen, die man im der Parameterdatei finden kann. Einen Parameter der Bezeichnung PAS gibt es nicht.

PAS Signale bis Start = Start Degree Number = SDN = 4 bei dir.

Ich habe eine Vermutung, warum der Motor bei dir nicht zügig wieder einschaltet. Es liegt nicht bzw. nur ganz wenig an SDN=4!

Wenn es leicht bergauf geht und du legst einen Tretstopp ein, dann ändert doch vielleicht die Geschwindigkeit. Wenn es nicht am Tretstop liegt und es liebt nicht am Tretstop an sich, was ändert sich dann noch bei einem Tretstop? Warum machst du überhaupt einen Tretstop, wenn es bergauf geht. Das meine ich mit «unpräzise».
Die Frage sollte nicht sein, warum ich einen Tretstopp mache, sondern, warum der Motor so spät wieder einsteigt.... Und gerade weil ja bergauf bei einem Tretstopp die Geschwindigkeit schnell abfällt, ist es unlogisch das der Wiedereinstieg des Motors so zögerlich läuft.

Anderer Fall... Ich fahr durch eine Senke. Trete Bergab, dann Tretstopp und rollen lassen, und wenn es wieder bergauf geht fange ich wieder an zu treten. Nun steigt der Motor erst nach besagter Anzahl der Kurbelumdrehungen wieder ein. Eine halbe Umdrehung akzeptiere ich ja noch, aber nicht 2,5 - 3.
 
K

kfs

Dabei seit
02.04.2016
Beiträge
925
Punkte Reaktionen
333
Jetzt bist du präzise. Du fährst in einem zu grossen Gang.
TS = Time to Stop = Tretunterstützung Stop Zeit = 6 = 60ms bei dir. (die Einheit von TS ist 10ms)

Daraus errechnet sich die minimale Tretkurbelfrequenz zu f = 1 / (24 x TS) = 1 / (24 x 0.060s) = 0.69 Umdrehungen pro s = 41 Umdrehungen pro Minute

Der Motor stellt bei dir erst an, wenn die Kadenz grösser als 41 ist.

TS=10 bzw. = 100ms wäre dir wahrscheinlich lieber. Ist aber auch gefährlich, wenn du dir der Gefahr nicht bewusst bist. Bei mir ist TS = 5 = 50ms und bei Bedarf kurz Daumengas bzw. besser wäre, frühzeitig in kleineren Gang schalten.
 
P

Philipp22

Dabei seit
24.06.2022
Beiträge
8
Punkte Reaktionen
0
Hallo, ich bin neu hier. Ich habe mich schon den Fred “überflogen” und nichts passendes gefunden.
Ich habe mein Fahrrad vor kurzem mit einem BBS01 nachgerüstet. Jetzt ist mir beim fahren aufgefallen dass wenn ich aufhöre zu treten und wieder anfange zu treten der Motor ca. 8 Sekunden für das hochlaufen benötigt. Das gleiche passiert auch beim betätigen der Bremsen. Beim Schaltvorgang (Schaltsensor) wird jedoch danach wieder voll unterstützt.
Ich finde es ja sinnvoll das der Motor langsam hoch läuft beim anfahren. Aber wenn man schon Geschwindigkeit hat dann könnte er ja immer gleich voll unterstützen.
Gibt es hierfür Einstellmöglichkeiten? Wie ist eure Erfahrung hier? Ist das normal?
 
Delphis1982

Delphis1982

Dabei seit
25.02.2021
Beiträge
1.273
Punkte Reaktionen
1.689
Ort
Blankenfelde-Mahlow
Details E-Antrieb
Ghost ASX 5500 Model 2014, BBSHD, 52V, 30A, 20Ah.
Die Motoren haben eine sogenannte Anlauframpe, die dafür sorgt, dass der Motor nicht von 0 auf jetzt die volle Wattzahl auf die Kette prügelt.
Bei Bafang geht diese Einstellmöglichkeit von 1-8. Je höher die Zahl, desto langsamer das Anlaufen.
Schnapp dir die Software und stelle die Rampe etwas kleiner ein.
Ich hab sie bei mir auf Maximum gesetzt, also auf 8, bei dem HD ist das auch dringend nötig.
Setz sie bei dir auf etwa 2, dann reagiert der Motor knackiger. Aber sei vorsichtig.
Das heißt nämlich, dass nach kurzer Zeit die volle Wattzahl anliegt. Wenn der Motor bis dahin nicht halbwegs auf Touren gekommen ist und es geht bergauf, kann das beim 01 sehr hässlich werden.
Ich würde es vermeiden, dies Rampe auf 1 zu setzen, das belastet ganz schön die Kette und das Getriebe, den Motor/Controller unter Umständen ebenfalls.
Ist mir schon passiert, dass es die Kette beim Anfahren gnadenlos zerrissen hat. Bergauf ziemlich kacke.

Was die Bremshebelabschaltung betrifft, der Controller geht beim betätigen der Bremse ja davon aus, dass das Fahrzeug zum Stillstand kommt,
daher auch die Anlauframpe sobald die Unterstützung wieder einsetzen soll.
Bei der Schaltunterbrechung dagegen ist man ja IN FAHRT und das weiß der Controller auch, da ist die Rampe witzlos.
Wenn dir das nicht passt, schließ die Bremshebel an den Schaltsensoranschluss an.
 
Zuletzt bearbeitet:
P

Philipp22

Dabei seit
24.06.2022
Beiträge
8
Punkte Reaktionen
0
Aha super vielen dank. Ich habe es auf 8 gesetzt weil ich dachte dadurch beschleunigt er schneller. Aber wenn das umgekehrt ist dann würde das mein Problem erklären:). Vielen dank für deine schnelle Antwort.
 
P

Philipp22

Dabei seit
24.06.2022
Beiträge
8
Punkte Reaktionen
0
Hallo nochmal, habe es gleich mal getestet. Also es gibt beim anfahren einen merklichen Unterschied. Also wenn das Rad still steht. Wenn ich jedoch fahre ist die Rampe unverändert 8s lange. Das ist eher das Gegenteil von dem was ich möchte.
 
Delphis1982

Delphis1982

Dabei seit
25.02.2021
Beiträge
1.273
Punkte Reaktionen
1.689
Ort
Blankenfelde-Mahlow
Details E-Antrieb
Ghost ASX 5500 Model 2014, BBSHD, 52V, 30A, 20Ah.
Geht es um die Anfahrrampe nach einem Bremsvorgang oder nachdem du einfach nur etwas rollen lässt und dann wieder antrittst?
 
P

Philipp22

Dabei seit
24.06.2022
Beiträge
8
Punkte Reaktionen
0
Es geht um den Bremsvorgang und wenn ich einfach rollen lasse. Bei beiden dauert die Rampe gleich lange. Wobei es mir hier wichtiger wäre dass nach dem rollen lassen die Rampe kürzer wäre.
 
C

calmato60

Dabei seit
18.06.2022
Beiträge
10
Punkte Reaktionen
1
Jetzt bist du präzise. Du fährst in einem zu grossen Gang.
TS = Time to Stop = Tretunterstützung Stop Zeit = 6 = 60ms bei dir. (die Einheit von TS ist 10ms)

Daraus errechnet sich die minimale Tretkurbelfrequenz zu f = 1 / (24 x TS) = 1 / (24 x 0.060s) = 0.69 Umdrehungen pro s = 41 Umdrehungen pro Minute

Der Motor stellt bei dir erst an, wenn die Kadenz grösser als 41 ist.

TS=10 bzw. = 100ms wäre dir wahrscheinlich lieber. Ist aber auch gefährlich, wenn du dir der Gefahr nicht bewusst bist. Bei mir ist TS = 5 = 50ms und bei Bedarf kurz Daumengas bzw. besser wäre, frühzeitig in kleineren Gang schalten.
Danke. Ich werde es ausprobieren. Allerdings war ich ganz sicher schneller als 41 in der Kadenz. Ich bin eher ein schnell treter. Finde ich erstens angenehmer für mich und zweitens ist das gesünder für den Motor. Ich liege in der Kadenz meistens zwischen 50 und 75.

Irgendwie passt diese Theorie nicht zu meinem Fahr-Stil....
 
P

Philipp22

Dabei seit
24.06.2022
Beiträge
8
Punkte Reaktionen
0
Danke. Ich werde es ausprobieren. Allerdings war ich ganz sicher schneller als 41 in der Kadenz. Ich bin eher ein schnell treter. Finde ich erstens angenehmer für mich und zweitens ist das gesünder für den Motor. Ich liege in der Kadenz meistens zwischen 50 und 75.

Irgendwie passt diese Theorie nicht zu meinem Fahr-Stil....
Die Frage sollte nicht sein, warum ich einen Tretstopp mache, sondern, warum der Motor so spät wieder einsteigt.... Und gerade weil ja bergauf bei einem Tretstopp die Geschwindigkeit schnell abfällt, ist es unlogisch das der Wiedereinstieg des Motors so zögerlich läuft.

Anderer Fall... Ich fahr durch eine Senke. Trete Bergab, dann Tretstopp und rollen lassen, und wenn es wieder bergauf geht fange ich wieder an zu treten. Nun steigt der Motor erst nach besagter Anzahl der Kurbelumdrehungen wieder ein. Eine halbe Umdrehung akzeptiere ich ja noch, aber nicht 2,5 - 3.
Die Frage sollte nicht sein, warum ich einen Tretstopp mache, sondern, warum der Motor so spät wieder einsteigt.... Und gerade weil ja bergauf bei einem Tretstopp die Geschwindigkeit schnell abfällt, ist es unlogisch das der Wiedereinstieg des Motors so zögerlich läuft.

Anderer Fall... Ich fahr durch eine Senke. Trete Bergab, dann Tretstopp und rollen lassen, und wenn es wieder bergauf geht fange ich wieder an zu treten. Nun steigt der Motor erst nach besagter Anzahl der Kurbelumdrehungen wieder ein. Eine halbe Umdrehung akzeptiere ich ja noch, aber nicht 2,5 - 3.
Ich bin zwar auch neu hier aber bei mir fühlt sich das ja ähnlich an. Vielleicht haben wir auch das gleiche Problem. Dadurch dass der Motor nur langsam hochläuft fühlt es sich so an dass er nach dem Tretstopp lange brauch um wieder auf Drehzahl zu kommen.
Ich habe mal zum testen das Fahrrad auf den Sattel gestellt. Da kann man dann auch wirklich hören wann der Motor wieder beschleunigt.
 
E

einbein

Dabei seit
03.04.2011
Beiträge
728
Punkte Reaktionen
338
Ort
47178 Duisburg
Details E-Antrieb
Ab jetzt Umgebaut auf BBS01
Moin

Mit der Rampe da war doch mal was.
Beim Frühstück eben viel es mir wieder ein.
Geh mal in die Einstellung für Handgas und stell da die max Geschwindigkeit auf 40
 
1337hm

1337hm

Dabei seit
03.08.2018
Beiträge
127
Punkte Reaktionen
54
Ort
Hannover
Details E-Antrieb
Shengyi DGW12C & DGW22C, AKM Q75 alle mit KT S06S
Moin,

Ich habe nun ehrlich gesagt nicht die 138 Seiten gelesen und weiß nicht so richtig wo nach ich suchen soll, deshalb frage ich direkt :)

Ich habe seit kurzem auch einen BBS02 verbaut, bin mit meinem Setup nun auch weitgehend zufrieden.

Aber eine Eigenschaft stört mich noch: Warum dreht der Motor oberhalb der max. Geschwindigkeit noch weiter und wird nicht vollständig ausgeschaltet?

Der Motor unterstützt dann nicht mehr, dreht aber irgendwie, man hört es und die angezeigte Leistung springt zwischen 36W und 72W.

Kann ich dieses Verhalten irgendwie beeinflussen?
 
Shylock

Shylock

Dabei seit
27.12.2021
Beiträge
14
Punkte Reaktionen
12
Ort
Essen
Details E-Antrieb
Bafang BBS02
Ich habe genau den selben Motor aber meiner hört definitiv bei der eingestellten Geschwindigkeit auf zu unterstützen. Auch ist ab da die Leistungsanzeige auf 0
Es wäre sicherlich von Vorteil, wenn du mal deine Einstellungen (Screenshot/ Foto) postest.
 
M

Msengxxl

Dabei seit
21.05.2019
Beiträge
8
Punkte Reaktionen
4
Hallo,

ich hab versucht, die 137 Seiten Thread zu durchforsten aber leider keine Antwort auf die einfache Frage gefunden: Weiß jemand welche Getriebeuntersetzung der Bafang BBS01 hat ? Ich hab das ganze Internet durchforstet aber nirgends was dazu gefunden...Ich vermute irgendwas mit 20:1 oder so...
 
dagobird

dagobird

Dabei seit
11.03.2016
Beiträge
212
Punkte Reaktionen
163
Ort
61440 Oberursel/Ts
Details E-Antrieb
Cute Q100CST, TSDZ2, Bafang BBS01B
Hallo,

ich hab versucht, die 137 Seiten Thread zu durchforsten aber leider keine Antwort auf die einfache Frage gefunden: Weiß jemand welche Getriebeuntersetzung der Bafang BBS01 hat ? Ich hab das ganze Internet durchforstet aber nirgends was dazu gefunden...Ich vermute irgendwas mit 20:1 oder so...
Wenn man bei google "Bafang BBS01 reduction ratio" eingibt, findet man den Wert 1:21,9.
 
1337hm

1337hm

Dabei seit
03.08.2018
Beiträge
127
Punkte Reaktionen
54
Ort
Hannover
Details E-Antrieb
Shengyi DGW12C & DGW22C, AKM Q75 alle mit KT S06S
Ich habe genau den selben Motor aber meiner hört definitiv bei der eingestellten Geschwindigkeit auf zu unterstützen. Auch ist ab da die Leistungsanzeige auf 0
Es wäre sicherlich von Vorteil, wenn du mal deine Einstellungen (Screenshot/ Foto) postest.

Ich habe noch ein wenig im Thread geschaut und auf Seite ~80 Geo321 gefunden, der bereits seit 4 Jahren das selbe Problem hat, aber keine Lösung finden konnte.

Mein Setup beruht auf der Datei von Üps die ich hier irgendwo gefunden habe, wobei ich nur noch die Levels und den Reifendurchmesser verändert habe.

Hast du sonst mal deine setup Datei für mich?
 

Anhänge

  • Screenshot_2022-07-31-13-01-20-440_com.mkopa.speeed.jpg
    Screenshot_2022-07-31-13-01-20-440_com.mkopa.speeed.jpg
    53,9 KB · Aufrufe: 23
  • Screenshot_2022-07-31-13-01-28-257_com.mkopa.speeed.jpg
    Screenshot_2022-07-31-13-01-28-257_com.mkopa.speeed.jpg
    44,4 KB · Aufrufe: 21
  • Screenshot_2022-07-31-13-01-39-776_com.mkopa.speeed.jpg
    Screenshot_2022-07-31-13-01-39-776_com.mkopa.speeed.jpg
    42,3 KB · Aufrufe: 20
  • Screenshot_2022-07-31-13-01-51-498_com.mkopa.speeed.jpg
    Screenshot_2022-07-31-13-01-51-498_com.mkopa.speeed.jpg
    46,1 KB · Aufrufe: 20
  • Screenshot_2022-07-31-13-01-46-182_com.mkopa.speeed.jpg
    Screenshot_2022-07-31-13-01-46-182_com.mkopa.speeed.jpg
    59,9 KB · Aufrufe: 23
Thema:

Programmierung BBS01 / BBS02

Programmierung BBS01 / BBS02 - Ähnliche Themen

erledigt Prophete Navigator 3.0 Mittelmotor (28", 2015, BBS01, e-novation, wenig gefahren) (auch Tausch): Bis auf den Akku voll funktionstüchtig (tiefentladen ca. 1V/Zelle), hier im Flachland bleibe ich nach 30 km Probefahrt lieber bei meinen...
Oben