Programmierung BBS01 / BBS02

Diskutiere Programmierung BBS01 / BBS02 im Controller/Regler, Fahrerinformation, Elektronik Forum im Bereich Diskussionen; Da im Amiforum in letzter Zeit offenbar der Knoten geplatzt ist, wollte ich mal fragen wers hier schon probiert hat. Bei mir scheitert es noch an...
Z

ziltoid81

Mitglied seit
28.01.2014
Beiträge
762
Details E-Antrieb
BBS01@Cannondale Prophet, Qulbix Raptor@QS205@12kW
Da im Amiforum in letzter Zeit offenbar der Knoten geplatzt ist, wollte ich mal fragen wers hier schon probiert hat.

Bei mir scheitert es noch an irgendwas, ein anderer User hat mit dem selben USB Interface wie meinem eine Verbindung hergestellt, konnte umprogrammieren und allgemein gibt es jetzt immer mehr wo es funktioniert.
Vielleicht ist es mein Laptop oder das Interface ist defekt, habe ein neues bestellt und werde am WE nochmal ausgiebig testen.

Man benötigt ein USB-TTL Interface für um die 3-10 Euro, offenbar funktioniert es aber nicht mit allen.

Werde nachher noch die Pinbelegung des Steckers zum Controller und eine Anleitung posten, falls es noch jemand probieren will.

Weis garnicht ob es bei Freeride jetzt mittlerweile geklappt hat.
 
Z

ziltoid81

Mitglied seit
28.01.2014
Beiträge
762
Details E-Antrieb
BBS01@Cannondale Prophet, Qulbix Raptor@QS205@12kW
Das mit dem Editieren ist ja hier auch ein Traum......

Egal weiter gehts.

Hier erstmal die Pinbelegung zum Controller/Motor

medium_controller1klein.jpg?0


Hab hier auf Arbeit nur Paint, sry.

GND sollte klar sein, wenn man PL und P+ brückt, soll sich der Controller einschalten.
RX und TX sind die Signalleitungen fürs Interface worüber dann Daten empfangen und gesendet werden.

Nun eine Anleitung die ich auch nur ausm Amiforum übernehme, es scheint wie gesagt bei anderen zu funktionieren.

Vorne Weg, der Stecker führt auch ohne angeschlossenen Akku noch Strom, stochert da nicht mit Metall drin rum.

Ihr benötigt als erstes ein Interface.
Ich hatte das hier bestellt:
http://www.ebay.de/itm/281274548169?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1439.l2649

Bei mir funktioniert es irgendwie noch nicht, bei anderen im Forum doch......optisch ist es das gleiche Interface, auch der IC ist der gleiche.
Um auszuschliessen das es mein PC, Interface ist, habe ich noch ein anderes bestellt......mal schauen.

Dann benötigt ihr die Software von Bafang, die geistert mit Sicherheit noch im Endless Sphere Forum rum, ich werde hier nichts öffentlich hochladen, da ich mir über die rechtliche Seite nicht im klaren bin.
Die gepackte Datei heisst bei mir "controllerst.zip", vielleicht findet google ja auch was.

1.) Akku, Batterie abklemmen
2.) Oben gezeigten Stecker abziehn, es gibt ihn so nur einmal, also sollte das keiner verwechseln können.
3.) GND, TX und RX mit geeigneten Kabeln an das Interface anschliessen. RX und TX vertauschen laut den Leuten wo es funktioniert.

Anmerkung: Es ist extrem eng in dem Stecker, ihr müsst euch Anschlüsse suchen die ihr da rein bekommt, die aber perfekt isoliert sind, im Stecker darf sich nichts berühren.
Alternativ könnt ihr natürlich den Stecker gegen einen anderen 5 poligen Tauschen und den Spass neu verlören.

4.) PL und P+ brücken.
5.) alles nochmal kontrollieren
6.) Interface in den PC stecken, Akku anschliessen, Software öffnen (über die Reihenfolge bin ich mir noch nicht im klaren, sollte so aber passen)
7.) In der Software noch den Comport wählen der für euer Interface vergeben wurde, Baudrate ist auf 1200 voreingestellt. Auf connect klicken und der Spass sollte funzen.

Abschliessend will ich nochmal ausdrücklich sagen, das es bei mir halt noch nicht funktioniert und ich hier nicht mit Weisheit um mich werfen will.
Ich bin ein Laie, aber vielleicht finden wir zusammen die Lösung.
Wenn ich Schwachsinn erzähle, bitte ich natürlich um Richtigstellung.
 
X

xango

Mitglied seit
10.05.2010
Beiträge
904
Details E-Antrieb
Puma/MAC 10T HR; 11S6P Liion 18650-35E
Hallo Ziltoid,

hast Du für den 2303 Chip von Prolific den entsprechden Treiber installiert?
 
Z

ziltoid81

Mitglied seit
28.01.2014
Beiträge
762
Details E-Antrieb
BBS01@Cannondale Prophet, Qulbix Raptor@QS205@12kW
Ja hab den von der Prolific Homepage.

Im Taskmanager ist alles ok, keine Fehler und Gerät funktioniert "angeblich".
 
W

winido

Mitglied seit
01.02.2009
Beiträge
1.529
Ort
bei Kaiserslautern
Das hier scheint der gleiche Händler, wie ein Link im Ami-Forum, zu sein, da sind dann gleich passende Kabel dabei. Die Lieferung wird wohl ein paaaar Taaage brauchen.
Beim im Ami-Forum verlinkten Händler wird bei mir angezeigt, dass der Händler keine Ware anbietet, obwohl sich andererseits einzelne lieferbare Artikel sehr wohl anzeigen lassen, die auch nach Deutschland geliefert werden. Was auch immer das bedeuten soll:confused:.
 
Z

ziltoid81

Mitglied seit
28.01.2014
Beiträge
762
Details E-Antrieb
BBS01@Cannondale Prophet, Qulbix Raptor@QS205@12kW
Genau den PL2303HX hab ich auch.......wird wohl mein Lappi und/oder Verkabelung sein, wobei Durchgang haben alle Kabel.
 
W

winido

Mitglied seit
01.02.2009
Beiträge
1.529
Ort
bei Kaiserslautern
Das hier scheint der gleiche Händler, wie ein Link im Ami-Forum, zu sein, da sind dann gleich passende Kabel dabei. Die Lieferung wird wohl ein paaaar Taaage brauchen. ...
Hat gar nicht sooo laaaange gedauert, heute schon angekommen(y). Mal sehen, ob ich am Wochenende dazu komme, mal erste Versuche zu unternehmen.
 
W

winido

Mitglied seit
01.02.2009
Beiträge
1.529
Ort
bei Kaiserslautern
Hatte am 20. in China bestellt und ging umgehend in den Versand; comelili und axeprice ist ein und derselbe Händler.

tinxi kannte ich aus Karlsruhe, da war der Versand zügig. Wenn das seit dem 23. wirklich aus Frankfurt unterwegs ist, sollte es selbst als Warensendung, nach meiner Erfahrung in den letzten Wochen, längst eingetroffen sein; aber die geben ja 8-12 Werktage + 1-2 WT für den Versand an, da glaube ich eher an China als Standort. Da hilft wohl nur Geduld.
 
Z

ziltoid81

Mitglied seit
28.01.2014
Beiträge
762
Details E-Antrieb
BBS01@Cannondale Prophet, Qulbix Raptor@QS205@12kW
Ich darf noch keinen Fall öffnen, als ich auf kaufen geklickt habe stand beim Versand ein früheres Datum als wir jetzt haben.:mad:
 
Zuletzt bearbeitet:
F

--freeride--

Mitglied seit
20.12.2010
Beiträge
2.364
Ort
MUC
Details E-Antrieb
2x BBS02,Leafmotor,elfkw,SWXK5,BoschDU45,BionX
Bei mir funktioniert es auch noch nicht. Ich hab gestern nochmal 3 USB-Adapter bestellt, macht dann insgesammt 5 Stück... damit gibt es dann noch einen Versuch.
 
E

einbein

Mitglied seit
03.04.2011
Beiträge
601
Ort
47178 Duisburg
Details E-Antrieb
Ab jetzt Umgebaut auf BBS01
Ist denn jemand schon weiter gekommen?
 
E

einbein

Mitglied seit
03.04.2011
Beiträge
601
Ort
47178 Duisburg
Details E-Antrieb
Ab jetzt Umgebaut auf BBS01
Habe noch ein Problem, mein Stecker zum Kontroller sieht ein wenig anders aus und hat mehr Pins
Kann mir da jemannd weiter helfen?

Gruß Reiner
 
E

einbein

Mitglied seit
03.04.2011
Beiträge
601
Ort
47178 Duisburg
Details E-Antrieb
Ab jetzt Umgebaut auf BBS01
Jau das soll er wohl sein, kann nicht nachschauen bin im Job.
Danke Dir
 
F

--freeride--

Mitglied seit
20.12.2010
Beiträge
2.364
Ort
MUC
Details E-Antrieb
2x BBS02,Leafmotor,elfkw,SWXK5,BoschDU45,BionX
Ich hab den Stecker rausgeschnitten, tue mir aber schwer da was zur Verfügung zu stellen, da kommt man sehr schnell durcheinander und dann rauchts...
 
E

einbein

Mitglied seit
03.04.2011
Beiträge
601
Ort
47178 Duisburg
Details E-Antrieb
Ab jetzt Umgebaut auf BBS01
Dann Frage ich mal andersrum, Stecker tauschen gegen anderen ist ja kein Problem.
Aber wie hast Du deine Anschlüße also gnd rx tx identifiziert.
Ich komm da nicht weiter weil das sche§$%$§ Display c961 nicht aufgeht

Gruß Reiner
 
F

--freeride--

Mitglied seit
20.12.2010
Beiträge
2.364
Ort
MUC
Details E-Antrieb
2x BBS02,Leafmotor,elfkw,SWXK5,BoschDU45,BionX
Das Display ist verklebt ich habs geöffnet und hatte hier mal Bilder reingestellt. Dunkelrot ist Vbat, grau ist Pl grün undgelb ist Rx/Tx, schwarz ist GND die 6te Leitung ist blind und führt ins leere.
 
Thema:

Programmierung BBS01 / BBS02

Oben