Bafang max drive programmieren

Diskutiere Bafang max drive programmieren im Controller/Regler, Fahrerinformation, Elektronik Forum im Bereich Diskussionen; Hallo liebe Forummitglieder, wie ich schon in einigen Beiträgen gelesen habe, sind hier einige Mitglieder, die sich gut mit dem Programmieren...
S

sergej65388

Mitglied seit
19.08.2019
Beiträge
9
Hallo liebe Forummitglieder,

wie ich schon in einigen Beiträgen gelesen habe, sind hier einige Mitglieder, die sich gut mit dem Programmieren der Bafang-Controllern auskennen und mir (hoffentlich) bei meinem Problem ebenfalls helfen können.

Nachdem ich bei meiner letzten Tour etwas mehr Unterstützung erhofft habe, habe ich mir ein Programmierkabel bestellt und wollte mir die Parameter im Controller anschauen und eventuell nach Anleitung einige Optimierung vornehmen. Nachdem ich alles angeschlossen hatte und die Stufen eingestellt habe, habe ich jetzt das Problem, dass nach einigen Umdrehungen des Motors oder auch bei der Walkfunktion die Batterie auf dem Display (C966 mit 5 Stufen) anfängt zu blinken und ich keine Unterstützung mehr habe. Die Einstellungen, die ich vorab exportiert habe, habe ich probiert wieder zu importieren, aber leider ohne Erfolg. Derzeit habe ich zwei Versionen von der Software gefunden. Kann mir bitte jemand sagen, welche Software für Max Drive verwendet werden soll und hätte jemand die Default Parameter bzw. einen Tipp für mich, was es sein kann?

Vielen Dank vorab
 
W

wsxws

Mitglied seit
21.08.2019
Beiträge
6
Hallo,
habe 2 Fischer 1860 mit BafangMaxdrive
Wenn du nur die Geschwindigkeit programmieren möchtest geht jede Bafang-Softwareversion, auch die ohne Torque-Reiter
Da kannste dann halt die Unterstütungsraten und die Geschwindigkeit in % je Stufe einstellen und/oder auch die Maxgeschwindigkeit verändern (wenn du das nicht mehr übers DIsplay steuern lässt)
Ich habe auch die Software mit Torque getestet, aber mir persönlich sind die Einstellungen auf dem Tab deutlich zu kompliziert.
 
S

sergej65388

Mitglied seit
19.08.2019
Beiträge
9
Vielen Dank für eure Antworten.
Hab schon mal die Software ohne den Reiter "Torque" probiert und habe danach die Probleme bekommen. Eigentlich wollte ich eine bessere Unterstütung am Berg, da ich das Gefühl hatte, dass durch das langsame Treten auch weniger Unterstütung ankommt. Seitdem kann ich leider überhaupt nicht fahren. :cautious:
Werde am Wochenende mal die Software mit dem zusätzlichen Reiter testen. Hätte jemand von euch eventuell seine Parameter für mich und habt ihr ein Display mit 9 oder 5 Stufen oder spielt es für die Einstellung in der Software keine Rolle?

Ich habe das Display, welches auch in der folgenden Anleitung beschrieben wird: https://www.bottecchia.com/wp-content/uploads/2017/02/Bafang-Max-Drive-System-Manua-DE-1.pdf

PS: was ich noch vergessen habe. Ich habe einen 48V Akku und beim Auslesen des Controllers wird mir 60V angezeigt. Dadurch kann ich den Wert Löw Battery Protect nicht unter 48 einstellen
 
Zuletzt bearbeitet:
W

wsxws

Mitglied seit
21.08.2019
Beiträge
6
da scheint was nicht zu stimmen.
hab dir mal von meinem bike die original.el angehängt (die mit torque).
kommt von einem Fischer Ecu 1860, dürfte dem MaxyDrive aber wohl recht egal sein.
Einfach .txt am Ende entfernen.
Ist aber natürlich ohne jede Gewär.

PS: hab ein DIsplay mit 5 Stufen, sollte aber eigentlich egal sein. Ich kann deswegen die PAS 1,3,5 und 7 auch auf 0 setzten, weil die nicht benutz werden, aber letzendlich isses komplett egal.
 

Anhänge

S

Stud54

Mitglied seit
09.06.2019
Beiträge
144
Vielen Dank für eure Antworten.
Hab schon mal die Software ohne den Reiter "Torque" probiert und habe danach die Probleme bekommen. Eigentlich wollte ich eine bessere Unterstütung am Berg, da ich das Gefühl hatte, dass durch das langsame Treten auch weniger Unterstütung ankommt. Seitdem kann ich leider überhaupt nicht fahren. :cautious:
Werde am Wochenende mal die Software mit dem zusätzlichen Reiter testen. Hätte jemand von euch eventuell seine Parameter für mich und habt ihr ein Display mit 9 oder 5 Stufen oder spielt es für die Einstellung in der Software keine Rolle?

Ich habe das Display, welches auch in der folgenden Anleitung beschrieben wird: https://www.bottecchia.com/wp-content/uploads/2017/02/Bafang-Max-Drive-System-Manua-DE-1.pdf

PS: was ich noch vergessen habe. Ich habe einen 48V Akku und beim Auslesen des Controllers wird mir 60V angezeigt. Dadurch kann ich den Wert Löw Battery Protect nicht unter 48 einstellen
Ich hab nen Ultra. Du solltest die Software mit dem Torque Reiter verwenden, nutze ich auch.

Ich habe das C18 im Einsatz, 5 Stufen Eco, 5 Sport. Kann dir gerne meine Einstellungen mal zukommen lassen.

Übrigens waren meine beiden 5 poligen HIGO Stecker nach 10 Mal an und abstecken hinüber und ich hatte nur noch Fehler.
Vielleicht hatte ich nur Pech oder die sind einfach Mist, habe auf andere HIGO umgebaut.

Gruß
 
S

sergej65388

Mitglied seit
19.08.2019
Beiträge
9
da scheint was nicht zu stimmen.
hab dir mal von meinem bike die original.el angehängt (die mit torque).
kommt von einem Fischer Ecu 1860, dürfte dem MaxyDrive aber wohl recht egal sein.
Einfach .txt am Ende entfernen.
Ist aber natürlich ohne jede Gewär.

PS: hab ein DIsplay mit 5 Stufen, sollte aber eigentlich egal sein. Ich kann deswegen die PAS 1,3,5 und 7 auch auf 0 setzten, weil die nicht benutz werden, aber letzendlich isses komplett egal.
Vielen Dank für deine Rückmeldung. Habe mal am Wochenende versucht die Parameter einzuspielen, aber leider ohne Erfolg. Habe weiterhin das Problem, dass nach einer Zeit das Batteriesymbol anfängt zu blinken und ich dann keine Unterstütung habe.
Ich habe gesehen, dass in den Einstellungen 41V eingestellt war. Ich kann jedoch die 41V nicht übernehmen. Als kleinsten Wert wird mir von der Software 48V vorgegeben. Kann es hiermit was zu tun haben?
 
S

sergej65388

Mitglied seit
19.08.2019
Beiträge
9
Ich hab nen Ultra. Du solltest die Software mit dem Torque Reiter verwenden, nutze ich auch.

Ich habe das C18 im Einsatz, 5 Stufen Eco, 5 Sport. Kann dir gerne meine Einstellungen mal zukommen lassen.

Übrigens waren meine beiden 5 poligen HIGO Stecker nach 10 Mal an und abstecken hinüber und ich hatte nur noch Fehler.
Vielleicht hatte ich nur Pech oder die sind einfach Mist, habe auf andere HIGO umgebaut.

Gruß
Hab es auch mit einem neuen Kabel und sogar einem neuen Display probiert. Keine Veränderung
 
S

Stud54

Mitglied seit
09.06.2019
Beiträge
144
Aber mit der Software kommst du schon drauf....kannst den Flash lesen und auch wieder speichern?
 
lusi22

lusi22

Mitglied seit
09.04.2017
Beiträge
2.007
Ort
Erzgebirge
Details E-Antrieb
Bafang_MaxDrive Brose_sMag/BMZ
Als kleinsten Wert wird mir von der Software 48V vorgegeben. Kann es hiermit was zu tun haben?
Genau darin wird dein Problem liegen. Sobald du das Rad nutzt fällt die Spannung ein wenig unter die 48v, es blinkt dann als wäre der Akku leer und geht aus.
Ob man dies allerdings mit der "einfachen" Software beheben kann und wie es dazu kam, das kann ich dir leider auch nicht sagen. Evtl. lässt es sich nur mit dem Werksdongle und der dazugehörigen Software" BEST" beheben.
 
S

sergej65388

Mitglied seit
19.08.2019
Beiträge
9
Aber mit der Software kommst du schon drauf....kannst den Flash lesen und auch wieder speichern?
Ich kann mich verbinden und die Daten auslesen. Beim Schreiben muss ich von den 41V auf 48V ändern, dann kann ich auch schreiben. Komisch ist halt nur, dass auf der rechten Seite 60V steht. Kann man irgendwie das in der Software ändern, dass es nicht auf 48V als kleinsten Wert springt?
 
lusi22

lusi22

Mitglied seit
09.04.2017
Beiträge
2.007
Ort
Erzgebirge
Details E-Antrieb
Bafang_MaxDrive Brose_sMag/BMZ
Ich denke mal rechts unter "Controller Info" - Nominal Voltage wird er 60V haben. Normal geht das nicht umzustellen. Evtl. hat er aber eine .el geflasht, welche dafür einen Wert hinterlegt hatte?
Normal soll man ja deshalb nie Dateien aus fremden Quellen verwenden, sondern zuerst die Daten mit "Read" auslesen, dann im Programm händisch ändern und danach mit "Write" zurück schreiben. Nur so kann man sicher sein nichts ungewollt zu ändern.

Nachdem ich alles angeschlossen hatte und die Stufen eingestellt habe,
Hast du wirklich erst "Read" ausgeführt und dann geändert? Oder doch eher eine fremde Datei geladen, Diese angepasst und auf deinen Controller geschrieben?
 
S

Stud54

Mitglied seit
09.06.2019
Beiträge
144
So mache ich das ja eigentlich auch immer. Original auslesen und speichern, Kopie erstellen, umbenennen und anpassen.
Hmmmm.....
 
S

sergej65388

Mitglied seit
19.08.2019
Beiträge
9
Ich meine unter Controller Info "nominal Voltage" (siehe Screenshot) Bevor ich das erste Mal was gemacht habe, habe ich die Werte exportiert (leider ohne den Reiter "Torque") und dann händisch laut Anleitung paar Werte geändert. Komischerweise standen da schon die 60V. Hab jetzt am Wochenende erst Mal von allen Reitern Screenshots gemacht
 

Anhänge

S

sergej65388

Mitglied seit
19.08.2019
Beiträge
9
Ich habe mir jetzt die Software von Stefan Penoff runtergeladen, da dort auch der Source-Code dabei ist. Jetzt wollte ich die Prüfung von Low Battery Protection raussuchen und verändern, sodass ich bei 60V auch einen Wert unter 48V einstellen kann. Weiß jemand welche Prüfung dafür zuständig ist? Habe den gesamten Code mir angeschaut, aber leider finde ich es nicht.
 
W

wsxws

Mitglied seit
21.08.2019
Beiträge
6
Ich denke nicht, dass du das wirst lösen können. Die eigentlichen Schwierigkeiten liegen meines Erachtens klar in der falschen Meldung des Controllers, dass du 60V hast. (bei 25A mach wären das 1500 Watt, Hut ab).
Wenn du noch Garantie hast kannste da nur einen Techniker kommen lassen, wenn nicht besorg dir einen neuen Controller.
In den .el files (also auch die ausgelesenen original-files) gibt es keine Parameter zu Spannung oder max-Strom. DIese scheine fest im Controller verankert zu sein. (du kannst die .el-files einfach mit einem Texteditor öffnen und nachsehen, was alles drinsteht)
 
Zuletzt bearbeitet:
S

sergej65388

Mitglied seit
19.08.2019
Beiträge
9
Ich denke nicht, dass du das wirst lösen können. Die eigentlichen Schwierigkeiten liegen meines Erachtens klar in der falschen Meldung des Controllers, dass du 60V hast. (bei 25A mach wären das 1500 Watt, Hut ab).
Wenn du noch Garantie hast kannste da nur einen Techniker kommen lassen, wenn nicht besorg dir einen neuen Controller.
In den .el files (also auch die ausgelesenen original-files) gibt es keine Parameter zu Spannung oder max-Strom. DIese scheine fest im Controller verankert zu sein. (du kannst die .el-files einfach mit einem Texteditor öffnen und nachsehen, was alles drinsteht)
Leider habe ich keine Garantie mehr. Habe mir auch einen neuen Controller bestellt und angeschlossen. Dann bekomme ich einen Fehlercode 10.

Wenn ich es richtig verstehe, dann hatte ich laut der exportieren. el einen Wert von 32 bei Low Battery Protection eingestellt.
 
Thema:

Bafang max drive programmieren

Werbepartner

Oben