Arduino Pedelec Controller

Diskutiere Arduino Pedelec Controller im ForumsController Forum im Bereich Controller/Regler, Fahrerinformation, Elektronik; Servus, nach ~ 600km bin ich nun wieder mit dem Rad zurück :) wie versprochen habe ich Bilder vom Umbau hier gepostet...
J

JosiaM

Mitglied seit
01.11.2016
Beiträge
31
Ort
Lemgo
Hallo zusammen,

ist in diesen 50 Seiten irgendwo das Platinen-Layout versteckt?

Möchte für ein Uni-Projekt den Regler nachbauen, einige Bauteile sollen auch geändert werden, aber eine Struktur wäre schon sehr hilfreich für den Anfang. Nur anhand des Schaltplanes und Stückliste zusammenbasteln ist etwas mühselig.
 
J

jenkie

Mitglied seit
28.06.2011
Beiträge
1.705
Details E-Antrieb
elfkw HR + Forumscontroller
Nein das Platinenlayout liegt hier nicht - das bringt den meisten Nutzern nicht viel.
Wenn du noch Sachen modifizieren willst wird dir das wahrscheinlich nicht viel Zeit ersparen. Kannst dich aber per PN melden wenn du es doch brauchen solltest (Eagle).
 
M

Mavabo

Mitglied seit
29.06.2018
Beiträge
1
Hallo Leute..
Ich bin Maarten aus Holland, 68 jahre jung und habe mein Trek (BionX) bike umgebaut nach eine 'normale' version.
Dazu habe ich ein version 1.5 pedelec gebaut und dabei ein ACS758LCB-100B-PFF-T bidirectional 100 A, 20mV/A stromtaster benutzt.
Ich habe wenig erfahrung mit das programmieren.
Meine frage ist: welche zeilen ins programm sollte ich anpassen müssen, so das alles gut functioniert?
 
mxxt

mxxt

Mitglied seit
01.06.2017
Beiträge
172
Details E-Antrieb
ElfKW VR + ElfKW Leistungsc. + Forumscontroller
...Mal eine blöde Frage. Wie heissen diese beigen JST-Stecker, die überall auf dem Forumscontroller drauf sind? Ich kann die Bezeichnung nirgends finden, um sie zu besorgen.
 
T

triton-mole

Mitglied seit
28.07.2012
Beiträge
850
Ort
99817Eisenach
Details E-Antrieb
Yuba Mundo, Golden Motor Frontmotor, 36V, 20A
Zum Arduino habe ich mal eine Frage:
Ich habe für einen FC 1.3 und einen FC 1.2 jeweils einen neuen Arduino v3.3 bei Reichelt bestellt.
Jetzt ist das Problem, daß ich auf dem FC mit dem Arduino den Gasgriff nicht erkennen kann und auch keinen PAS.
Auch die Batteriespannung kann ich nicht "sehen", wenn ich mit dem Konfigurator Live-Daten abrufe.
Ich konnte durch Hochsetzen des Throttle_out_min-Wertes den Motor immerhin schon mal zum Anlaufen bringen.
Die beiden FCs sollten OK sein, sie waren vor Kurzem bei @jenkie zur Überprüfung.

Jetzt habe ich gerade festgestellt, daß es beim Reichelt den originalen Arduino V3.3 gibt, der 16 GPIOs hat und einen V3 kompatiblen, der 20 GPIOs hat.
Kann es sein, daß ich den kompatiblen hätte bestellen sollen?
Oder anders gefragt: Kann es sein, daß die fehlenden GPIO genau die sind, die ich für PAS, Gasgriff, Spannungsmessung und was weiß ich noch brauche?
Ich habe im Netz nach einer Version-History für den Arduino Nano gesucht, aber nicht gefunden.

Kann mir da bitte mal jemand Nachhilfe geben? Ich stehe etwas auf dem Schlauch.

Danke!
 
J

jenkie

Mitglied seit
28.06.2011
Beiträge
1.705
Details E-Antrieb
elfkw HR + Forumscontroller
Ich habe mir mal den 3.3er angeschaut, zumindest von den Bildern her sollte er eigentlich gehen. Der FC ist auf den Arduino Nano V3.0 ausgelegt aber ich sehe keine Belegungsunterschiede bei den Pins. Sicher, dass du die richtige HW-Version eingestellt und auch in der Arduino IDE den richtigen Nano mit 328P Prozessor ausgewählt hast?

Kannst du bei beiden FC-Versionen keine Akkuspannung sehen? Zeig doch mal deine Konfiguration.
 
T

triton-mole

Mitglied seit
28.07.2012
Beiträge
850
Ort
99817Eisenach
Details E-Antrieb
Yuba Mundo, Golden Motor Frontmotor, 36V, 20A
So, heute bin ich dazu gekommen, weiter der Sache nachzugehen.
Ich bekomme auch dem seriellen Monitor nach dem Start des Arduino ein oder zwei mal eine Ausgabe, dann ist Ruhe.
Zur Kontrolle hatte ich jetzt mal den funktionierenden Arduino aus meinem Mundo angeschlossen. Der liefert schön alle Sekunde eine Zeile.

Also: Ich habe hier inzwischen vier Arduinos. Zwei originale V3.3 und zwei China-Clones V3.0, die alle den gleichen Fehler zeigen und alle neu sind! Alle geben mir ein oder zwei Zeilen auf dem seriellen Monitor aus und dann ist Schluß. Das habe ich jetzt erst mal ohne FC getestet.

Da liegt der Verdacht nahe, daß der Fehler in der Software liegen könnte.
Da fiel mir gerade unter der Dusche ein, daß ich auf dem Desktop noch eine ältere Software liegen haben könnte.
Dort ist ein Pedelec-Configurator V1.31 installiert, der keine Updates mehr holen kann, weil er kein SSL kann.
Wenn ich dort Software flashe, scheint der Arduino zu arbeiten! Zumindest bekomme ich jetzt auf dem V3.3 im seriellen Monitor alles Sekunde eine Zeile Info geliefert.
Für mich sieht es so aus, als ob ein Fehler in der Arduino-Software auf Github versteckt ist, der einen Nano zum Aussteigen bringt.
@jenkie könntest Du der Sache bitte mal nachgehen?
 
J

jenkie

Mitglied seit
28.06.2011
Beiträge
1.705
Details E-Antrieb
elfkw HR + Forumscontroller
Es klingt so, als würden sie in die Unterspannungsabschaltung gehen und der Arduino damit heruntergefahren (vom FC-Code). Was für Spannungen bekommst du denn am seriellen Monitor angezeigt und was für Unterspannungslevels hast du programmiert? Zeig doch mal deine Konfiguration.

Ich schau parallel mal in den Code - wenn ich hier mit V1.40 einen Arduino Nano programmiere, funktioniert er ohne Abschaltung. Spannungsmessung 0,xV wenn er nicht auf einem FC-Board steckt.
 
T

triton-mole

Mitglied seit
28.07.2012
Beiträge
850
Ort
99817Eisenach
Details E-Antrieb
Yuba Mundo, Golden Motor Frontmotor, 36V, 20A
Fehler gefunden!

Nachdem ich den FC 1.2 oder 1.3 eigentlich ohne Einschalttaster betreiben wollte, hatte ich den Idle-Shutdown auf 0 gesetzt, in der Annahme, daß das bewirkt, daß der FC nicht in den Idle-Shutdown geht. Aber leider passiert das Gegenteil! Er geht SOFORT in den Idle-Shutdown.
Ich könnte kotzen! Ich war gerade schon wieder 2 Stunden vergeblich in der Gluthitze an der Karre gestanden, um dann festzustellen, daß ich es immer noch nicht zum Laufen bekomme. Erst dachte ich, ich hätte irgendwie auf dem Laptop einen neuen Code, als auf dem PC. Habe dann alles wieder eingepackt und bin zurück in die Wohnung, wo och dann nochmal in Ruhe am Tisch den ganzen Kram durchgegangen bin und plötzlich:
Gerade noch nach dem Flashen den seriellen Monitor gehabt und jetzt nach neuem Flashen (Idle-Shutdown auf 0 gesetzt) ist wieder Sense!

Es ist also nicht vorgesehen, den FC ohne Idle-Shutdown zu betreiben?????? Ich wollte ihn einfach den ganzen Tag eingeschaltet lassen. Ich weiß nämlich nicht, wo ich einen Taster für Einschalten vernünftig unterbringen soll.
Wen juckt's, wenn der Natrieb den ganzen Tag an ist? Mein Antrieb wird jetzt auch den ganzen Tag nicht abgeschaltet. Erst, wenn ich den Akku zum Laden abhänge, geht er aus.
 
T

triton-mole

Mitglied seit
28.07.2012
Beiträge
850
Ort
99817Eisenach
Details E-Antrieb
Yuba Mundo, Golden Motor Frontmotor, 36V, 20A
So, Update:

Nachdem das Gewitter (sowohl meiner Laune, als auch vom Wetter) die Temperaturen gekühlt haben, habe ich mich heute Abend noch mal dran gestellt und es nochmal versucht.
Für den Ein-Aus-Knopf am 1.3er FC habe ich doch ein Plätzchen gefunden und der Timeout steht jetzt auf Maximum und der FC tut, was er soll.

Aber ich könnte jetzt anfangen ein Roman zu schreiben darüber, daß es mich über 1 Jahr Arbeit gekostet hat, um EIN Fahrrad mit einem FC zum Laufen zu bekommen........
Endlich!
Es läuft!
Und möge es lange laufen!

Danke @jenkie für die Erfindung des FC!
 
R

rraymakers

Mitglied seit
10.06.2019
Beiträge
3
Ich habe auch interesse in einde FC 2.2.
Oder veilleicht das Project neues Leben einblasen und umsetzen nach eine EPS32 met Wifi oder etwas anderes.
Ich kenne mich aus mit arduino aber bin noch eine Beginner
 
S

steinbock

Mitglied seit
06.04.2012
Beiträge
324
Ort
Tübingen
Details E-Antrieb
elfkw HR mit CST + Forumscontroller + VESC 6.41
G

guancio

Mitglied seit
23.06.2019
Beiträge
2
[QUOTE = "capricorn, post: 1223317, member: 10397"]
Yes, please contact user "jenkie" if you are interested in one of the controllers. Since version 2.0, the ATmega MCU is integrated into the PCB.
[/ QUOTE]
Thanks
 
E

evbkezzz

Mitglied seit
02.08.2019
Beiträge
1
@jenkie
Hallo jenkie,
Zunächst einmal vielen Dank für das tolle Projekt.
Ich plane, einen Friktionsantrieb mit Pedalunterstützung zu bauen, der eine VESC 4.6-Steuerung verwendet. Dieser erfüllt die meisten meiner Bedürfnisse. Ich liebe Heimwerken und plane dies selbst zu bauen. Ich habe jedoch einige Fragen.
Ich sehe, dass dieses Projekt einen Arduino Nano verwendet. Kann ich dies auf einem ESP32 oder einem ähnlichen Controller verwenden? Ich möchte auch ein Farbdisplay verwenden, ist das möglich?
Diese Software zeigt die Batterieladung, die Batteriekapazität und die Geschwindigkeit auf dem LCD an. Stellt VESC diese Informationen bereit? Aus den Softwarebildern geht hervor, dass dies auch das Bremsen mit Regeneration unterstützt. Wie richte ich dies ein, um das Bremsen mit Regeneration mit meinem VESC 4.6 zu verwenden?

Danke und Grüße
Andy

Ich kann kein Deutsch und benutze daher Google Translate, um diesen Text zu schreiben. Bitte entschuldigen Sie eventuelle Fehler.
 
mxxt

mxxt

Mitglied seit
01.06.2017
Beiträge
172
Details E-Antrieb
ElfKW VR + ElfKW Leistungsc. + Forumscontroller
Und möge es lange laufen!
Bei mir läuft es 2 Jahre und 2500km ohne einen einzigen Zwischenfall. Bin von der Zuverlässigkeit begeistert.
Hab es allerdings auch ein halbes Jahr lang in Betrieb genommen, aber man muss eben die Struktur verstehen, um seine Wünsche implementieren zu können.

Ich möchte auch ein Farbdisplay verwenden, ist das möglich?
Zu dem Display kann ich nur sagen, es wurde schonmal mit einem frei käuflichen OLED realisiert. Sollte glaube im FC Display-Thema sein:
ForumsController: Eine Display-Diskussion
 
H

heikoxxxx

Mitglied seit
18.08.2019
Beiträge
2
Hallo zusammen,

Erstmal vielen Dank für das tolle Projekt. Gestern bin ich mit meinem Eigenbau der Version 1.5 fertig geworden und das Bike tut schonmal. Jedoch haben sich doch noch kleinere Fragen aufgetan und ich hoffe ihr könnt mir helfen.

Wenn das Bike nicht benutzt wird schwankt die Watt Anzeige zwischen - 8 und +10 Watt. Ist dies normal und liegt einfach an der Auflösung des Nano ADC Wandlers? Gibt es Tipps wie man das eventuell noch etwas ausfiltern kann?

Zudem habe ich die 30A Variante des Chips und mußte den offset etwas hochregeln da ich sonst immer im Negativ Bereich war. +1.2
Muss an der Amplitude etwas geändert werden?

Zudem steht im Konfigurator, daß für den StVO Betrieb beim Motor normal 500W eingestellt wird. Ich war der Meinung bei 250 Watt ist Ende, oder zählt hier die tatsächliche Wirkleistung?

Die Auto cruise Funktion funktioniert nur wenn Bremsen angeschlossen sind?

Vielen Dank schonmal im voraus.

LG Heiko
 
J

jenkie

Mitglied seit
28.06.2011
Beiträge
1.705
Details E-Antrieb
elfkw HR + Forumscontroller
Wenn das Bike nicht benutzt wird schwankt die Watt Anzeige zwischen - 8 und +10 Watt.
Das ist normal. Du kannst für die Anzeige einfach noch ein bisschen mitteln, wenn dich das stört.

Zudem habe ich die 30A Variante des Chips und mußte den offset etwas hochregeln da ich sonst immer im Negativ Bereich war. +1.2
Muss an der Amplitude etwas geändert werden?
Das musst du mit einem Multimeter prüfen. Typischerweise braucht man da aber nichts zu verändern.

Ich war der Meinung bei 250 Watt ist Ende, oder zählt hier die tatsächliche Wirkleistung?
250W ist die Nennabgabeleistung, also mechanisch. Typische 250W/36V Systeme haben 14A Akkustrom, was 500W elektrisch entspricht.

Die Auto cruise Funktion funktioniert nur wenn Bremsen angeschlossen sind?
Die habe ich noch nie genutzt :D
 
Thema:

Arduino Pedelec Controller

Werbepartner

Oben